Re: [PATCH i-g-t 1/4] lib: add the ability to include a description with a test

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Tue, Oct 28, 2014 at 03:10:25PM +0000, Damien Lespiau wrote:
> On Tue, Oct 28, 2014 at 03:03:53PM +0000, Thomas Wood wrote:
> > +extern const char* __igt_test_description __attribute__((weak));
> > +#define IGT_TEST_DESCRIPTION(a) const char* __igt_test_description = a;
> 
> It's usual to omit the ';' here to have the macro invokation always
> finish with a ';' (your next patch mixes both).

Since you need to go through them all anyway small style bikeshed, but I
think the multi-line arguments to macros look funny.  What about

#define IGT_TEST_DESCPIPTION const char * __igt_test_description

and use them like

IGT_TEST_DESCRIPTION =
"blbl"
"blbl";

Imo slightly easier on the eyes ;-)

Otherwise this looks like a good start. So either way pls push after
addressing Damien's feedback.
-Daniel
-- 
Daniel Vetter
Software Engineer, Intel Corporation
+41 (0) 79 365 57 48 - http://blog.ffwll.ch
_______________________________________________
Intel-gfx mailing list
Intel-gfx@xxxxxxxxxxxxxxxxxxxxx
http://lists.freedesktop.org/mailman/listinfo/intel-gfx





[Index of Archives]     [Linux USB Devel]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]
  Powered by Linux