On Sat, Mar 8, 2014 at 7:49 PM, <sagar.a.kamble@xxxxxxxxx> wrote: > From: Sagar Kamble <sagar.a.kamble@xxxxxxxxx> > > v1: Added 128x128 and 256x256 cursor size support. > > v2: Refined the test to use igt_subtest_f and automate enumeration. > > Signed-off-by: Sagar Kamble <sagar.a.kamble@xxxxxxxxx> Hm, do you have an update of this patch to use the drm ioctl to query the max cursor size and correctly skip 128x128 and higher? Also adding the additional modes into an enum looks a bit strange. I'm it would be simpler to explicit pass the cursor size and have an outer loop over all of them, i.e. for (cursor_size = 64 ; cursor_size <= 256; cursor_size *= 2) { igt_require(cusror_max >= cursor_size); /* lists of all the existing subtests with a igt_subtest_f("subtest-%s", cursor_size) */ } Adding all the indirections with the enum switches makes the code imo harder to read, and for testcases we want to aim for simple straightforward code. -Daniel -- Daniel Vetter Software Engineer, Intel Corporation +41 (0) 79 365 57 48 - http://blog.ffwll.ch _______________________________________________ Intel-gfx mailing list Intel-gfx@xxxxxxxxxxxxxxxxxxxxx http://lists.freedesktop.org/mailman/listinfo/intel-gfx