On Thu, Dec 12, 2013 at 05:30:14PM +0200, Jani Nikula wrote: > > -#define INTEL_INFO(dev) (to_i915(dev)->info) > > +#define INTEL_INFO(dev) ((const struct intel_device_info *)&to_i915(dev)->info) > > If that were an inline function you wouldn't have to cast to add const: > > static inline const struct intel_device_info * > intel_info(const struct drm_device *dev) > { > return to_i915(dev)->info; > } > > I'm not insisting on this bikeshed, though. True, I'd happily review a follow-up patch once the series has landed :) -- Damien _______________________________________________ Intel-gfx mailing list Intel-gfx@xxxxxxxxxxxxxxxxxxxxx http://lists.freedesktop.org/mailman/listinfo/intel-gfx