On Tue, Jan 17, 2023 at 02:33:05PM +0200, Jani Nikula wrote: > Let's see if this sticks. Suddenly all of these 'bridge_dev' makes some sense to me. I believe we could enjoy the refactor here and add some documentation about this... at least the name Graphics Memory Controller Hub name... I also wonder if we should make this a child device now that it is really organized... But anyway, everything can be a follow up, the current refactor is already a very good clean up step, so for the series: Reviewed-by: Rodrigo Vivi <rodrigo.vivi@xxxxxxxxx> > > Jani Nikula (4): > drm/i915: add gmch substruct to struct drm_i915_private > drm/i915/gmch: split out soc/intel_gmch > drm/i915/gmch: mass rename dev_priv to i915 > drm/i915/gmch: move VGA set state to GMCH code > > drivers/gpu/drm/i915/Makefile | 1 + > drivers/gpu/drm/i915/display/intel_vga.c | 32 +--- > drivers/gpu/drm/i915/gt/intel_ggtt_gmch.c | 2 +- > drivers/gpu/drm/i915/i915_driver.c | 145 +----------------- > drivers/gpu/drm/i915/i915_drv.h | 10 +- > drivers/gpu/drm/i915/soc/intel_gmch.c | 171 ++++++++++++++++++++++ > drivers/gpu/drm/i915/soc/intel_gmch.h | 18 +++ > 7 files changed, 204 insertions(+), 175 deletions(-) > create mode 100644 drivers/gpu/drm/i915/soc/intel_gmch.c > create mode 100644 drivers/gpu/drm/i915/soc/intel_gmch.h > > -- > 2.34.1 >