On Fri, 05 Apr 2013, Ben Widawsky <ben at bwidawsk.net> wrote: > Only the very first switch doesn't take the path. > > Signed-off-by: Ben Widawsky <ben at bwidawsk.net> > --- > drivers/gpu/drm/i915/i915_gem_context.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/drivers/gpu/drm/i915/i915_gem_context.c b/drivers/gpu/drm/i915/i915_gem_context.c > index 94d873a..aa080ea 100644 > --- a/drivers/gpu/drm/i915/i915_gem_context.c > +++ b/drivers/gpu/drm/i915/i915_gem_context.c > @@ -390,7 +390,7 @@ static int do_switch(struct i915_hw_context *to) > * is a bit suboptimal because the retiring can occur simply after the > * MI_SET_CONTEXT instead of when the next seqno has completed. > */ > - if (from_obj != NULL) { > + if (likely(from_obj)) { Looking at the function, is this, uh, likely to make a difference? Same goes for the unlikely in patches 4/7. (Yes, patch_es_ 4/7 - there's *two* patches 4/7 in the series! :o) I'm just generally wary of adding (un)likely annotations. I don't think it matters that the annotation itself is obviously correct; IMHO the performance impact should matter. </bikeshed> BR, Jani. > from_obj->base.read_domains = I915_GEM_DOMAIN_INSTRUCTION; > i915_gem_object_move_to_active(from_obj, ring); > /* As long as MI_SET_CONTEXT is serializing, ie. it flushes the > -- > 1.8.2 > > _______________________________________________ > Intel-gfx mailing list > Intel-gfx at lists.freedesktop.org > http://lists.freedesktop.org/mailman/listinfo/intel-gfx