From: Paulo Zanoni <paulo.r.zanoni at intel.com> Hi All the patches on this series have already been sent to this mailing list (maybe with different titles) and received comments, except for patch 5, which was posted on pastebin by Daniel. This series contains new versions of the patches with all the bikesheds applied. Please notice that even though patches 6 and 8 are only coding style changes, they were created because we already had regressions caused by the confusing code. Thanks, Paulo Paulo Zanoni (8): drm/i915: create functions for the "unclaimed register" checks drm/i915: use FPGA_DBG for the "unclaimed register" checks drm/i915: clear the FPGA_DBG_RM_NOCLAIM bit at driver init drm/i915: use HAS_DDI on intel_hdmi.c and intel_display.c drm/i915: wait_event_timeout's timeout is in jiffies drm/i915: add aux_ch_ctl_reg to struct intel_dp drm/i915: rename sdvox_reg to hdmi_reg on HDMI context drm/i915: clarify confusion between SDVO and HDMI registers drivers/gpu/drm/i915/i915_dma.c | 4 ++ drivers/gpu/drm/i915/i915_drv.c | 31 ++++++++++---- drivers/gpu/drm/i915/i915_reg.h | 22 +++++----- drivers/gpu/drm/i915/intel_ddi.c | 4 +- drivers/gpu/drm/i915/intel_display.c | 42 ++++++++++--------- drivers/gpu/drm/i915/intel_dp.c | 77 ++++++++++++---------------------- drivers/gpu/drm/i915/intel_drv.h | 5 ++- drivers/gpu/drm/i915/intel_hdmi.c | 74 ++++++++++++++++---------------- drivers/gpu/drm/i915/intel_sdvo.c | 22 +++++----- 9 files changed, 140 insertions(+), 141 deletions(-) -- 1.7.10.4