On Wed, Feb 13, 2013 at 06:52:29PM +0200, Ville Syrj?l? wrote: > On Wed, Feb 13, 2013 at 04:23:27PM +0100, Daniel Vetter wrote: > > On Tue, Jan 29, 2013 at 06:13:34PM +0200, ville.syrjala at linux.intel.com wrote: > > > From: Ville Syrj?l? <ville.syrjala at linux.intel.com> > > > > > > If a GPU reset occurs while a page flip has been submitted to the ring, > > > the flip will never complete once the ring has been reset. > > > > > > The GPU reset can be detected by sampling the reset_counter before the > > > flip is submitted, and then while waiting for the flip, the sampled > > > counter is compared with the current reset_counter value. > > > > > > Signed-off-by: Ville Syrj?l? <ville.syrjala at linux.intel.com> > > > --- > > > drivers/gpu/drm/i915/intel_display.c | 14 +++++++++++++- > > > drivers/gpu/drm/i915/intel_drv.h | 3 +++ > > > 2 files changed, 16 insertions(+), 1 deletion(-) > > > > > > diff --git a/drivers/gpu/drm/i915/intel_display.c b/drivers/gpu/drm/i915/intel_display.c > > > index 4097118..e348a68 100644 > > > --- a/drivers/gpu/drm/i915/intel_display.c > > > +++ b/drivers/gpu/drm/i915/intel_display.c > > > @@ -2862,10 +2862,12 @@ static bool intel_crtc_has_pending_flip(struct drm_crtc *crtc) > > > { > > > struct drm_device *dev = crtc->dev; > > > struct drm_i915_private *dev_priv = dev->dev_private; > > > + struct intel_crtc *intel_crtc = to_intel_crtc(crtc); > > > unsigned long flags; > > > bool pending; > > > > > > - if (i915_reset_in_progress(&dev_priv->gpu_error)) > > > + if (i915_reset_in_progress(&dev_priv->gpu_error) || > > > + intel_crtc->reset_counter != atomic_read(&dev_priv->gpu_error.reset_counter)) > > > return false; > > > > > > spin_lock_irqsave(&dev->event_lock, flags); > > > @@ -6912,6 +6914,8 @@ static int intel_gen2_queue_flip(struct drm_device *dev, > > > if (ret) > > > goto err_unpin; > > > > > > + intel_crtc->reset_counter = atomic_read(&dev_priv->gpu_error.reset_counter); > > > > Ok no bikeshed about ->reset_counter, but a different one: Why does this > > need to be in the per-gen callback? Can't we just grab this before we call > > down into these callbacks? Imo races wrt the reset/hang code don't matter > > that much as long as we don't wait forever for a pageflip which won't > > happen. Hanging the gpu concurrently to pageflipping is undefined anyway > > right now ... > > Yeah. It could be moved to happen a little earlier, and thus avoid the > duplication. Applied the patch and moved the assignment around a bit, thanks. -Daniel -- Daniel Vetter Software Engineer, Intel Corporation +41 (0) 79 365 57 48 - http://blog.ffwll.ch