At Fri, 16 Mar 2012 22:51:22 -0300, Eugeni Dodonov wrote: > > [1 <text/plain; ISO-8859-1 (7bit)>] > On Fri, Mar 16, 2012 at 18:41, Takashi Iwai <tiwai at suse.de> wrote: > > > Add a new module optoin lvds_channel to specify the LVDS channel mode > > explicitly instead of probing the LVDS register value set by BIOS. > > This will be helpful when VBT is broken or incompatible with the > > current code. > > > > Signed-off-by: Takashi Iwai <tiwai at suse.de> > > --- > > drivers/gpu/drm/i915/i915_drv.c | 6 ++++++ > > drivers/gpu/drm/i915/i915_drv.h | 1 + > > drivers/gpu/drm/i915/intel_display.c | 5 +++++ > > 3 files changed, 12 insertions(+) > > > > diff --git a/drivers/gpu/drm/i915/i915_drv.c > > b/drivers/gpu/drm/i915/i915_drv.c > > index 308f819..eee6804 100644 > > --- a/drivers/gpu/drm/i915/i915_drv.c > > +++ b/drivers/gpu/drm/i915/i915_drv.c > > @@ -80,6 +80,12 @@ MODULE_PARM_DESC(lvds_downclock, > > "Use panel (LVDS/eDP) downclocking for power savings " > > "(default: false)"); > > > > +int i915_lvds_channel __read_mostly; > > +module_param_named(lvds_channel, i915_lvds_channel, int, 0400); > > > > As a minor bikeshedding, perhaps this variable would make more sense if > called 'i915_lvds_channel_mode' instead? > > I am fine with either spelling though, it just looks more semantically > correct to me. But in any case, OK, I'll fix in the next spin. thanks, Takashi > > Reviewed-by: Eugeni Dodonov <eugeni.dodonov at intel.com> > > -- > Eugeni Dodonov > <http://eugeni.dodonov.net/> > [2 <text/html; ISO-8859-1 (quoted-printable)>] >