On Sun, Jun 24, 2012 at 08:03:08PM -0300, Eugeni Dodonov wrote: > On 06/24/2012 11:42 AM, Daniel Vetter wrote: > > ... instead of calling each one for each generation indiviudally. > > > > Notice that we've already managed to be inconsistent, the resume path > > is missing an IS_VLV check. As a nice benefit we can mark all the > > platform specific enable/disable functions as static and hide them in > > intel_pm.c > > > > Signed-Off-by: Daniel Vetter <daniel.vetter at ffwll.ch> > > I have very similar patch for this as well (for HSW patches to come > somewhat later this week), you beat me on sending it by a few days. So: > > Reviewed-by: Eugeni Dodonov <eugeni.dodonov at intel.com> > > Just one (actually, two) bikesheds below. > > > +void intel_disable_gt_powersave(struct drm_device *dev) > > +{ > > + if (IS_IRONLAKE_M(dev)) > > + ironlake_disable_drps(dev); > > + if (INTEL_INFO(dev)->gen >= 6 && !IS_VALLEYVIEW(dev)) > > + gen6_disable_rps(dev); > > +} > > Just a minor bikeshed on those if loops. Wouldn't it be cleaner to > transform the 2nd if into 'else if'? I guess I'll leave that for your hsw patches ;-) -Daniel -- Daniel Vetter Mail: daniel at ffwll.ch Mobile: +41 (0)79 365 57 48