On Tue, Jan 25, 2011 at 09:54:59AM +0100, Vincent Guittot wrote: > Please find below a new proposal for adding trace events for cpu hotplug. > The goal is to measure the latency of each part (kernel, architecture) > and also to trace the cpu hotplug activity with other power events. I > have tested these traces events on an arm platform. > > Subject: [PATCH 1/2] add cpu hotplug tracepoints > > this patch adds new events for cpu hotplug tracing > * plug/unplug sequence > * core and architecture latency measurements > > Signed-off-by: Vincent Guittot <vincent.guittot@xxxxxxxxxx> > --- > kernel/cpu.c | 17 +++++++++++++++++ > 1 files changed, 17 insertions(+), 0 deletions(-) > > diff --git a/kernel/cpu.c b/kernel/cpu.c > index 156cc55..f04e9cf 100644 > --- a/kernel/cpu.c > +++ b/kernel/cpu.c > @@ -16,6 +16,9 @@ > #include <linux/mutex.h> > #include <linux/gfp.h> > > +#define CREATE_TRACE_POINTS > +#include <trace/events/cpu_hotplug.h> > + > #ifdef CONFIG_SMP > /* Serializes the updates to cpu_online_mask, cpu_present_mask */ > static DEFINE_MUTEX(cpu_add_remove_lock); > @@ -200,7 +203,9 @@ static int __ref take_cpu_down(void *_param) > int err; > > /* Ensure this CPU doesn't handle any more interrupts. */ > + trace_cpu_hotplug_arch_disable_start((unsigned int)(param->hcpu)); > err = __cpu_disable(); > + trace_cpu_hotplug_arch_disable_end((unsigned int)(param->hcpu)); You should create a cpu var instead of doing that not very beautiful cast twice. Probably we should eventually rename arch_disable into just disable. And same for die, because otherwise the name is quite long. Other than that, looks all good to me. Thanks. -- To unsubscribe from this list: send the line "unsubscribe linux-hotplug" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html