On Thu, Jul 15, 2021 at 10:32:07PM -0700, Arowa Suliman wrote: > Replaced the word Master with inclusive terms such as Main, Leader and > Owner. > diff --git a/doc/doxygen.conf b/doc/doxygen.conf > @@ -883,7 +883,7 @@ HHC_LOCATION = > # If the GENERATE_HTMLHELP tag is set to YES, the GENERATE_CHI flag > # controls if a separate .chi index file is generated (YES) or that > -# it should be included in the master .chm file (NO). > +# it should be included in the main .chm file (NO). This is a file name from the upstream project and while it is a comment here, I would not really change this in hostap.git unless the upstream project has already made a matching change. > diff --git a/src/drivers/driver_hostap.h b/src/drivers/driver_hostap.h > @@ -55,8 +55,8 @@ enum { > PRISM2_PARAM_MONITOR_ALLOW_FCSERR = 16, > PRISM2_PARAM_HOST_ENCRYPT = 17, > PRISM2_PARAM_HOST_DECRYPT = 18, > - PRISM2_PARAM_BUS_MASTER_THRESHOLD_RX = 19, > - PRISM2_PARAM_BUS_MASTER_THRESHOLD_TX = 20, > + PRISM2_PARAM_BUS_OWNER_THRESHOLD_RX = 19, > + PRISM2_PARAM_BUS_OWNER_THRESHOLD_TX = 20, This is a kernel interface defined in the Linux kernel tree. It would not be appropriate to rename these in hostap.git without the actual definition of the interface having been modified first. These two values have actually been commented out in the kernel code, so it would be fine to delete these two lines here (and well, also delete the other removed-from-kernel cases 1 and 6) instead. > diff --git a/src/p2p/p2p.h b/src/p2p/p2p.h > +++ b/src/p2p/p2p.h > @@ -486,7 +486,7 @@ struct p2p_config { > * case for this is to include passive-scan channels on devices that may > * not know their current location and have configured most channels to > * not allow initiation of radition (i.e., another device needs to take > - * master responsibilities). > + * leader responsibilities). > */ > struct p2p_channels cli_channels; This would be a really confusing change. The "master device" in this context is the currently used technical term for the wireless device that is in control of when a channel can be used, e.g., due to regulatory requirements related to radar detection. Renaming that to "leader" would make this difficult to understand since it removes that clear meaning. > diff --git a/src/utils/pcsc_funcs.c b/src/utils/pcsc_funcs.c > @@ -90,9 +90,9 @@ > > /* GSM files > * File type in first octet: > - * 3F = Master File > + * 3F = Main File > * 7F = Dedicated File > - * 2F = Elementary File under the Master File > + * 2F = Elementary File under the Main File > * 6F = Elementary File under a Dedicated File These are references to the names used in an external specification to the files. Renaming these would make it more difficult to understand this. I would not change these unless the external specification has been modified and would then use the exact name used there instead of trying to come up with something else within hostap.git. -- Jouni Malinen PGP id EFC895FA _______________________________________________ Hostap mailing list Hostap@xxxxxxxxxxxxxxxxxxx http://lists.infradead.org/mailman/listinfo/hostap