On Tue, 21 Mar 2023, Uwe Kleine-König wrote: > Hello, > > just some nitpicks: > > On Tue, Mar 21, 2023 at 01:04:33AM +0200, Menna Mahmoud wrote: > > Convert `to_gbphy_dev` and `to_gbphy_driver` macros into a > > static inline function. > > > > it is not great to have macro that use `container_of` macro, > > s/it/It/; s/macro/macros/; s/use/use the/; > > > because from looking at the definition one cannot tell what type > > it applies to. > > [...] > > -#define to_gbphy_dev(d) container_of(d, struct gbphy_device, dev) > > +static inline struct gbphy_device *to_gbphy_dev(const struct device *d) > > drivers/staging/greybus/gbphy.c always passes a variable named > "dev" to this macro. So I'd call the parameter "dev", too, instead of > "d". This is also a more typical name for variables of that type. I argued against that. Because then there are two uses of dev in the argument of container_of, and they refer to completely different things. It's true that by the way container_of works, it's fine, but it may be misleading. julia > > > +{ > > + return container_of(d, struct gbphy_device, dev); > > +} > > [...] > > }; > > -#define to_gbphy_driver(d) container_of(d, struct gbphy_driver, driver) > > +static inline struct gbphy_driver *to_gbphy_driver(struct device_driver *d) > > +{ > > + return container_of(d, struct gbphy_driver, driver); > > +} > > With a similar reasoning (and also to not have "d"s that are either > device or device_driver) I'd recommend "drv" here. > > Best regards > Uwe > > -- > Pengutronix e.K. | Uwe Kleine-König | > Industrial Linux Solutions | https://www.pengutronix.de/ | >
_______________________________________________ greybus-dev mailing list -- greybus-dev@xxxxxxxxxxxxxxxx To unsubscribe send an email to greybus-dev-leave@xxxxxxxxxxxxxxxx