On Tue 2020-05-26 10:37:36, Rafael J. Wysocki wrote: > On Mon, May 25, 2020 at 8:26 PM Krzysztof Wilczyński <kw@xxxxxxxxx> wrote: > > > > Use the new device_to_pm() helper to access Power Management callbacs > > (struct dev_pm_ops) for a particular device (struct device_driver). > > > > No functional change intended. > > > > Signed-off-by: Krzysztof Wilczyński <kw@xxxxxxxxx> > > --- > > drivers/acpi/device_pm.c | 5 +++-- > > 1 file changed, 3 insertions(+), 2 deletions(-) > > > > diff --git a/drivers/acpi/device_pm.c b/drivers/acpi/device_pm.c > > index 5832bc10aca8..b98a32c48fbe 100644 > > --- a/drivers/acpi/device_pm.c > > +++ b/drivers/acpi/device_pm.c > > @@ -1022,9 +1022,10 @@ static bool acpi_dev_needs_resume(struct device *dev, struct acpi_device *adev) > > int acpi_subsys_prepare(struct device *dev) > > { > > struct acpi_device *adev = ACPI_COMPANION(dev); > > + const struct dev_pm_ops *pm = driver_to_pm(dev->driver); > > I don't really see a reason for this change. > > What's wrong with the check below? Duplicated code. Yes, compiler can sort it out, but... new version looks better to me. Best regards, pavel > > > > - if (dev->driver && dev->driver->pm && dev->driver->pm->prepare) { > > - int ret = dev->driver->pm->prepare(dev); > > + if (pm && pm->prepare) { > > + int ret = pm->prepare(dev); -- (english) http://www.livejournal.com/~pavelmachek (cesky, pictures) http://atrey.karlin.mff.cuni.cz/~pavel/picture/horses/blog.html
Attachment:
signature.asc
Description: Digital signature
_______________________________________________ greybus-dev mailing list greybus-dev@xxxxxxxxxxxxxxxx https://lists.linaro.org/mailman/listinfo/greybus-dev