[EGIT PATCH 00/10] JGit cleanups

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Getting annoyed with all the noise I came up with series of cleanups. The
hunk parsing fixes are the one's I'm not really sure about, but my attempts
to find a case that would give an uncontrolled error did not find much
success.

-- robin

Robin Rosenberg (10):
  Require javadoc on protected methods in jgit core
  Rename the objectsUrl in the nested HttpObjectDB to
  Rename variables that hides others with different content in
    FetchProcess
  Rename a parameter i PackWriter that hides another with the same name
  Rename fields to avoid hiding of field names in ReadTreeTest
  Rename the gitDir fields to indicate they refer to another dir than
    the default
  Rename a parameter in PushProcessTest that hides another
  Drop unused end parameters in hunk parsing code
  Drop unused File arguments in IndexTreeWalker and WorkdirCheckout
  Drop an effectively unused parameter in IndexTreeWalker.

 .../.settings/org.eclipse.jdt.core.prefs           |    7 +-
 .../src/org/spearce/jgit/pgm/ReceivePack.java      |   10 +-
 .../src/org/spearce/jgit/pgm/TextBuiltin.java      |    9 +-
 .../src/org/spearce/jgit/pgm/UploadPack.java       |   10 +-
 .../tst/org/spearce/jgit/lib/ReadTreeTest.java     |  118 ++++++++++----------
 .../spearce/jgit/transport/PushProcessTest.java    |    4 +-
 .../.settings/org.eclipse.jdt.core.prefs           |    5 +-
 .../jgit/dircache/DirCacheBuildIterator.java       |    2 +-
 .../spearce/jgit/dircache/DirCacheIterator.java    |    2 +-
 .../src/org/spearce/jgit/lib/IndexTreeWalker.java  |   12 +-
 .../src/org/spearce/jgit/lib/ObjectId.java         |    2 +-
 .../src/org/spearce/jgit/lib/PackIndex.java        |    6 +-
 .../src/org/spearce/jgit/lib/PackWriter.java       |    8 +-
 .../jgit/lib/TreeVisitorWithCurrentDirectory.java  |    4 +-
 .../src/org/spearce/jgit/lib/WorkDirCheckout.java  |   17 ++--
 .../org/spearce/jgit/merge/StrategyOneSided.java   |    2 +-
 .../org/spearce/jgit/patch/CombinedHunkHeader.java |    2 +-
 .../src/org/spearce/jgit/patch/FileHeader.java     |   18 ++--
 .../src/org/spearce/jgit/patch/HunkHeader.java     |    6 +-
 .../src/org/spearce/jgit/patch/Patch.java          |    8 +-
 .../org/spearce/jgit/revplot/PlotCommitList.java   |    9 ++
 .../src/org/spearce/jgit/revplot/PlotWalk.java     |    4 +
 .../org/spearce/jgit/transport/DaemonService.java  |    4 +-
 .../org/spearce/jgit/transport/FetchProcess.java   |    8 +-
 .../org/spearce/jgit/transport/OpenSshConfig.java  |    2 +-
 .../spearce/jgit/transport/OperationResult.java    |   10 +-
 .../spearce/jgit/transport/PackedObjectInfo.java   |    2 +-
 .../src/org/spearce/jgit/transport/PushResult.java |    2 +-
 .../spearce/jgit/transport/RemoteRefUpdate.java    |    6 +-
 .../org/spearce/jgit/transport/TransportHttp.java  |   14 +-
 .../spearce/jgit/treewalk/WorkingTreeIterator.java |    7 +
 31 files changed, 173 insertions(+), 147 deletions(-)

--
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html

[Index of Archives]     [Linux Kernel Development]     [Gcc Help]     [IETF Annouce]     [DCCP]     [Netdev]     [Networking]     [Security]     [V4L]     [Bugtraq]     [Yosemite]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Linux SCSI]     [Fedora Users]

  Powered by Linux