On Wed, Dec 10, 2008 at 12:34:26AM -0800, Junio C Hamano wrote: > > +cat >dump <<'EOF' > > +#!/bin/sh > > +perl -e '$/ = undef; $_ = <>; s/./ord($&)/ge; print $_' < "$1" > > +EOF > > I'll squash in a change to make this part use $SHELL_PATH for > consistency. Thanks. It was cut-and-paste from t4030, so if we care, it might be worth changing there, too (and naming it "dump" instead of "hexdump", because it actually dumps in decimal :) ). But more importantly, the fixup you just pushed seems to have an extra ">dump": > +{ > + echo "#!$SHELL_PATH" > + cat >dump <<'EOF' > +perl -e '$/ = undef; $_ = <>; s/./ord($&)/ge; print $_' < "$1" > +EOF > +} >dump > +chmod +x dump -Peff -- To unsubscribe from this list: send the line "unsubscribe git" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html