Both of these patches can be considered cleanups: path_list is finally renamed to string_list (since it is not special to paths), and providing git_config() with a callback parameter. The latter change is only the beginning: existing callers are not fixed. These cleanup patches are rather large, so I though it would be best to provide them just at the end of the merge window. Johannes Schindelin (2): Rename path_list to string_list Provide git_config with a callback-data parameter Documentation/CodingGuidelines | 5 +- Documentation/technical/api-path-list.txt | 9 -- Documentation/technical/api-string-list.txt | 10 ++ Makefile | 4 +- alias.c | 5 +- archive-tar.c | 6 +- builtin-add.c | 6 +- builtin-apply.c | 6 +- builtin-blame.c | 10 +- builtin-branch.c | 6 +- builtin-cat-file.c | 2 +- builtin-checkout-index.c | 2 +- builtin-checkout.c | 2 +- builtin-clean.c | 6 +- builtin-clone.c | 2 +- builtin-commit-tree.c | 2 +- builtin-commit.c | 28 +++--- builtin-config.c | 26 +++--- builtin-diff-files.c | 2 +- builtin-diff-index.c | 2 +- builtin-diff-tree.c | 2 +- builtin-diff.c | 2 +- builtin-fast-export.c | 16 ++-- builtin-fetch-pack.c | 6 +- builtin-fetch.c | 20 ++-- builtin-fmt-merge-msg.c | 4 +- builtin-gc.c | 6 +- builtin-http-fetch.c | 2 +- builtin-init-db.c | 4 +- builtin-log.c | 18 ++-- builtin-ls-files.c | 2 +- builtin-ls-tree.c | 2 +- builtin-mailinfo.c | 2 +- builtin-mailsplit.c | 12 +- builtin-merge-base.c | 2 +- builtin-merge-recursive.c | 102 ++++++++++---------- builtin-mv.c | 43 ++++---- builtin-name-rev.c | 2 +- builtin-pack-objects.c | 6 +- builtin-read-tree.c | 4 +- builtin-reflog.c | 6 +- builtin-remote.c | 131 +++++++++++++------------- builtin-rerere.c | 54 +++++----- builtin-reset.c | 2 +- builtin-rev-list.c | 2 +- builtin-rev-parse.c | 2 +- builtin-revert.c | 2 +- builtin-rm.c | 2 +- builtin-shortlog.c | 42 ++++---- builtin-show-branch.c | 6 +- builtin-show-ref.c | 10 +- builtin-symbolic-ref.c | 2 +- builtin-tag.c | 6 +- builtin-unpack-objects.c | 2 +- builtin-update-index.c | 2 +- builtin-update-ref.c | 2 +- builtin-verify-pack.c | 2 +- builtin-verify-tag.c | 2 +- builtin-write-tree.c | 2 +- cache.h | 10 +- color.c | 4 +- color.h | 2 +- config.c | 27 +++--- connect.c | 7 +- convert.c | 4 +- daemon.c | 4 +- diff-lib.c | 22 ++-- diff.c | 8 +- diff.h | 4 +- fast-import.c | 6 +- hash-object.c | 2 +- help.c | 6 +- http.c | 6 +- imap-send.c | 4 +- index-pack.c | 6 +- ll-merge.c | 4 +- mailmap.c | 12 +- mailmap.h | 4 +- pager.c | 2 +- path-list.c | 134 -------------------------- path-list.h | 28 ------ receive-pack.c | 6 +- reflog-walk.c | 10 +- remote.c | 4 +- setup.c | 4 +- shortlog.h | 6 +- string-list.c | 138 +++++++++++++++++++++++++++ string-list.h | 28 ++++++ unpack-file.c | 2 +- var.c | 8 +- wt-status.c | 4 +- wt-status.h | 2 +- 92 files changed, 603 insertions(+), 592 deletions(-) delete mode 100644 Documentation/technical/api-path-list.txt create mode 100644 Documentation/technical/api-string-list.txt delete mode 100644 path-list.c delete mode 100644 path-list.h create mode 100644 string-list.c create mode 100644 string-list.h -- To unsubscribe from this list: send the line "unsubscribe git" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html