Re: [PATCH 1/4] "log" and friends: --children option

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Hi,

On Thu, 3 Apr 2008, Junio C Hamano wrote:

> @@ -1398,6 +1404,26 @@ int setup_revisions(int argc, const char **argv, struct rev_info *revs, const ch
>  	return left;
>  }
>  
> +static void add_child(struct rev_info *revs, struct commit *parent, struct commit *child)
> +{
> +	struct commit_list *l = xcalloc(1, sizeof(*l));
> +
> +	l->item = child;
> +	l->next = add_decoration(&revs->children, &parent->object, l);
> +}
> +
> +static void set_children(struct rev_info *revs)

I'd call this add_children().

Other than that, nicely done!  I did not think it was possible with as few 
changes.

Ciao,
Dscho
--
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html

[Index of Archives]     [Linux Kernel Development]     [Gcc Help]     [IETF Annouce]     [DCCP]     [Netdev]     [Networking]     [Security]     [V4L]     [Bugtraq]     [Yosemite]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Linux SCSI]     [Fedora Users]

  Powered by Linux