Ok, this goes on top of the five-commit series yesterday. The first two patches are pure fixes and cleanups, the third one does a fairly mechanical thing to get rid of implied usage of "the_index", and the last one actually splits up the source and destination index handling. Linus Torvalds (4): Fix tree-walking compare_entry() in the presense of --prefix Add 'const' where appropriate to index handling functions Make 'unpack_trees()' take the index to work on as an argument Make 'unpack_trees()' have a separate source and destination index The nice thing to see is how this clearly removes more lines than it adds, and the code is a bit more readable too, I think. builtin-checkout.c | 9 +++ builtin-commit.c | 2 + builtin-merge-recursive.c | 2 + builtin-read-tree.c | 23 +------ cache.h | 10 ++-- diff-lib.c | 47 ++----------- hash.c | 6 +- hash.h | 4 +- read-cache.c | 12 ++-- tree-walk.c | 3 + unpack-trees.c | 158 ++++++++++++++++++++++----------------------- unpack-trees.h | 15 +++-- 12 files changed, 128 insertions(+), 163 deletions(-) -- To unsubscribe from this list: send the line "unsubscribe git" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html