[PATCH 0/6] Builtin remote, v2

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



(Yes, I know, it is not v2, but I lost track...)

The only change is that path_list was renamed to string_list.  This is the
first patch, and pretty intrusive (even if the changes are all straight
forward...).

On Fri, 29 Feb 2008, Johannes Schindelin wrote:

> On Thu, 28 Feb 2008, Junio C Hamano wrote:
> 
> > Johannes Schindelin <Johannes.Schindelin@xxxxxx> writes:
> > 
> > > This is probably useful to a number of existing non-users of 
> > > path_list.
> > 
> > I suspect most of the non-users will stay non-users, until the thing 
> > is renamed to something more sensible.
> > 
> > The wholesale renaming, if we were to do so, should happen when things 
> > are quiet, and this is probably not a good time for it.
> 
> Right.  Will try to think of a patch when the right time has come.  Just 
> to make sure: "string_list"?

Just in case, I did it.  I have no problems resending it later, too, just 
wanted to let you know that I have the patches ready.

Johannes Schindelin (6):
      Rename path_list to string_list
      string-list: add functions to work with unsorted lists
      parseopt: add flag to stop on first non option
      Test "git remote show" and "git remote prune"
      Make git-remote a builtin
      builtin-remote: prune remotes correctly that were added with --mirror

 Documentation/CodingGuidelines            |    5 +-
 Documentation/technical/api-path-list.txt |    4 +-
 Makefile                                  |    7 +-
 builtin-blame.c                           |    4 +-
 builtin-commit.c                          |   20 +-
 builtin-fast-export.c                     |   14 +-
 builtin-fetch.c                           |   16 +-
 builtin-mailsplit.c                       |   12 +-
 builtin-merge-recursive.c                 |   96 +++---
 builtin-mv.c                              |   39 +-
 builtin-remote.c                          |  558 +++++++++++++++++++++++++++++
 builtin-rerere.c                          |   48 ++--
 builtin-shortlog.c                        |   42 ++--
 builtin-show-ref.c                        |   10 +-
 builtin.h                                 |    1 +
 contrib/examples/git-remote.perl          |  477 ++++++++++++++++++++++++
 diff-lib.c                                |   22 +-
 git-remote.perl                           |  477 ------------------------
 git.c                                     |    1 +
 mailmap.c                                 |   12 +-
 mailmap.h                                 |    4 +-
 parse-options.c                           |    2 +
 parse-options.h                           |    1 +
 path-list.c                               |  104 ------
 path-list.h                               |   22 --
 reflog-walk.c                             |   10 +-
 remote.c                                  |    3 +-
 remote.h                                  |    1 +
 shortlog.h                                |    6 +-
 string-list.c                             |  134 +++++++
 string-list.h                             |   28 ++
 t/t5505-remote.sh                         |   50 +++
 32 files changed, 1442 insertions(+), 788 deletions(-)
 create mode 100644 builtin-remote.c
 create mode 100755 contrib/examples/git-remote.perl
 delete mode 100755 git-remote.perl
 delete mode 100644 path-list.c
 delete mode 100644 path-list.h
 create mode 100644 string-list.c
 create mode 100644 string-list.h

--
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html

[Index of Archives]     [Linux Kernel Development]     [Gcc Help]     [IETF Annouce]     [DCCP]     [Netdev]     [Networking]     [Security]     [V4L]     [Bugtraq]     [Yosemite]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Linux SCSI]     [Fedora Users]

  Powered by Linux