Hi, On Mon, 4 Feb 2008, Daniel Barkalow wrote: > if (any_files) { > - if (o->merge) { > + if (skip_entry) { > + do > + o->pos++; > + while (o->pos < active_nr && > + !strcmp(active_cache[o->pos]->name, > + src[0]->name)); > + } else if (o->merge) { Maybe it is just me, but I would have thought while (++o->pos < active_nr) if (strcmp(active_cache[o->pos]->name, src[0]->name)) break; more readable. But that's maybe because I have trouble with do ... while constructs logically (I like to see the loop condition first, then the loop body). Ciao, Dscho - To unsubscribe from this list: send the line "unsubscribe git" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html