"git diff --numstat" used the same format as "git diff --stat" for renamed (and copied) files, except that filenames were not shortened when they didn't fit in the column width. This format is suitable for human consumption, but it cannot be unambiguously parsed. Instead of that always use final file name ("to" name) for numstat. It is possible to find name before rename when name after is known. This required to use pprint_rename (pretty print rename) during output (in the show_stats function) and not during parsing (in diffstat_add function). Adding from_name field to struct diffstat_t makes is_renamed bitfield redundant; nevertheless for the sake of clarity, readability and making this patch minimal (and because it would not reduce memory footprint) it was not removed, and its used not replaced by checking from_name field. Signed-off-by: Jakub Narebski <jnareb@xxxxxxxxx> --- Sorry for mistake: I have tested this commit, corrected it... and forgot to update patch to send. Previous version of this patch (from 7 May 2007) used instead of current only "to_name" format similar to git-diff-tree raw format for renames: added deleted TAB path for "src" TAB path for "dst" LF The problem was when -z option was used: how to separate end of record from end of from_name and start of to_name. For git-diff we have status to distinguish those; no such thing for numstat output. Previous version of patch used (or was to use actually, because of error in the code) added deleted TAB path for "src" NUL NUL path for "dst" NUL when -z option was used. This is left now for future --numstat-extended option... diff.c | 22 +++++++++++++--------- 1 files changed, 13 insertions(+), 9 deletions(-) diff --git a/diff.c b/diff.c index f780e3e..8039ac7 100644 --- a/diff.c +++ b/diff.c @@ -735,6 +735,7 @@ struct diffstat_t { int alloc; struct diffstat_file { char *name; + char *from_name; unsigned is_unmerged:1; unsigned is_binary:1; unsigned is_renamed:1; @@ -755,11 +756,14 @@ static struct diffstat_file *diffstat_add(struct diffstat_t *diffstat, } diffstat->files[diffstat->nr++] = x; if (name_b) { - x->name = pprint_rename(name_a, name_b); + x->from_name = xstrdup(name_a); + x->name = xstrdup(name_b); x->is_renamed = 1; } - else + else { + x->from_name = NULL; x->name = xstrdup(name_a); + } return x; } @@ -837,7 +841,7 @@ static void show_stats(struct diffstat_t* data, struct diff_options *options) struct diffstat_file *file = data->files[i]; int change = file->added + file->deleted; - if (!file->is_renamed) { /* renames are already quoted by pprint_rename */ + if (!file->is_renamed) { /* renames will be quoted by pprint_rename */ struct strbuf buf; strbuf_init(&buf, 0); if (quote_c_style(file->name, &buf, NULL, 0)) { @@ -846,6 +850,11 @@ static void show_stats(struct diffstat_t* data, struct diff_options *options) } else { strbuf_release(&buf); } + } else { + char *qname = pprint_rename(file->from_name, file->name); + free(file->name); + free(file->from_name); + file->name = qname; } len = strlen(file->name); @@ -982,12 +991,7 @@ static void show_numstat(struct diffstat_t* data, struct diff_options *options) printf("-\t-\t"); else printf("%d\t%d\t", file->added, file->deleted); - if (!file->is_renamed) { - write_name_quoted(file->name, stdout, options->line_termination); - } else { - fputs(file->name, stdout); - putchar(options->line_termination); - } + write_name_quoted(file->name, stdout, options->line_termination); } } -- 1.5.3.7 - To unsubscribe from this list: send the line "unsubscribe git" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html