On Thu, Mar 06, 2025 at 03:07:20AM -0800, Karthik Nayak wrote: > Patrick Steinhardt <ps@xxxxxx> writes: > > diff --git a/object.h b/object.h > > index 17f32f1103e..0a5293e9911 100644 > > --- a/object.h > > +++ b/object.h > > @@ -336,7 +338,7 @@ void object_array_remove_duplicates(struct object_array *array); > > */ > > void object_array_clear(struct object_array *array); > > > > -void clear_object_flags(unsigned flags); > > +void clear_object_flags(struct repository *repo, unsigned flags); > > > > Could you explain the reasoning behind only renaming the first two > functions with 'repo_'? Hm, good callout, and I can't really explain it because it's rather arbitrary. I'll drop the rename. Patrick