On Wed, Jan 15, 2025 at 09:56:23AM -0800, Junio C Hamano wrote: > Jeff King <peff@xxxxxxxx> writes: > > > use that everywhere. Possibly it could even do the argc/argv check, too, > > since every call site is going to be doing that itself. > > It would look something like this; I am not sure if I like the "this > may show help and exit if the user requested, but otherwise it is a > no-op" semantics, though. Yeah, I agree it is funny to have a "maybe noop, maybe exit" function. Perhaps a different name would help? I'd expect show_usage_help() to always do what the name says. Maybe check_help_option() or something? > +void show_usage_help(int ac, const char **av, > + const char * const *usagestr, > + const struct option *opts) > +{ > + if (ac == 2 && !strcmp(av[1], "-h")) { > + usage_with_options_internal(NULL, usagestr, opts, 0, 0); > + exit(0); > + } > +} I think parse-options will exit(129) in this case, and that's what t0012 insists upon. -Peff