"AreaZR via GitGitGadget" <gitgitgadget@xxxxxxxxx> writes: > From: Seija Kijin <doremylover123@xxxxxxxxx> > > If it is known that an int is either 1 or 0, This justification needs to be updated. The point of using flip = !flip pattern is not that you do not assume "1 or 0", but follow "zero or non-zero", which is more idiomatic in C. Other than that, > - flipped_block = (flipped_block + 1) % 2; > -+ flipped_block ^= 1; > ++ flipped_block = !flipped_block; it indeed is a good change to avoid modulo-2 like this. Thanks.