Steffen Prohaska <prohaska@xxxxxx> writes: > +int ref_abbrev_matches_full_with_rules(const char *abbrev_name, const char *full_name, const char **rules) > +{ > + const char **p; > + const int abbrev_name_len = strlen(abbrev_name); > + > + for (p = rules; *p; p++) { > + if (!strcmp(full_name, mkpath(*p, abbrev_name_len, abbrev_name))) { > + return 1; > + } > + } > + > + return 0; > +} > + How about calling this simply "ref_abbrev_matches()" or "refname_match()" which is even shorter? - To unsubscribe from this list: send the line "unsubscribe git" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html