On Mon, Oct 07, 2024 at 10:22:11AM +0000, Usman Akinyemi via GitGitGadget wrote: The title of this commit still has the "[Outreachy][Patch v1]" prefix that you likely want to remove. > From: Usman Akinyemi <usmanakinyemi202@xxxxxxxxx> > > Refactor t3404 to replace instances of `test` with `test_line_count()` > for checking line counts. This improves readability and aligns with Git's > current test practices. > > Signed-off-by: Usman Akinyemi <usmanakinyemi202@xxxxxxxxx> > > removed test I think this line got here by accident :) > --- > t/t3404-rebase-interactive.sh | 26 +++++++++++++------------- > 1 file changed, 13 insertions(+), 13 deletions(-) > > diff --git a/t/t3404-rebase-interactive.sh b/t/t3404-rebase-interactive.sh > index 96a65783c47..81f984f4cf5 100755 > --- a/t/t3404-rebase-interactive.sh > +++ b/t/t3404-rebase-interactive.sh > @@ -281,7 +281,8 @@ test_expect_success 'stop on conflicting pick' ' > test_cmp expect2 file1 && > test "$(git diff --name-status | > sed -n -e "/^U/s/^U[^a-z]*//p")" = file1 && > - test 4 = $(grep -v "^#" < .git/rebase-merge/done | wc -l) && > + grep -v "^#" < .git/rebase-merge/done > actual && We do not use a space after redirects, so this should be "<.git/rebase-merge/done" and ">actual". Other than that this patch looks good to me, thanks! Patrick