On Thu, Sep 26, 2024 at 03:50:09PM +0200, Patrick Steinhardt wrote: > On Tue, Sep 24, 2024 at 05:55:39PM -0400, Jeff King wrote: > > diff --git a/remote.c b/remote.c > > index 390a03c264..e291e8ff5c 100644 > > --- a/remote.c > > +++ b/remote.c > > @@ -2544,7 +2544,7 @@ struct ref *get_stale_heads(struct refspec *rs, struct ref *fetch_map) > > /* > > * Compare-and-swap > > */ > > -static void clear_cas_option(struct push_cas_option *cas) > > +void clear_cas_option(struct push_cas_option *cas) > > { > > int i; > > > > diff --git a/remote.h b/remote.h > > index a58713f20a..ad4513f639 100644 > > --- a/remote.h > > +++ b/remote.h > > @@ -409,6 +409,7 @@ struct push_cas_option { > > }; > > > > int parseopt_push_cas_option(const struct option *, const char *arg, int unset); > > +void clear_cas_option(struct push_cas_option *); > > Nit: I was wondering whether we'd also want to fix up this functions > name to conform to our style guide, which says this should be called > `push_cas_option_clear()` instead. But I don't mind it much, so please > feel free to ignore this nit. I'd prefer to punt on that for now, as the whole suite of "methods" for this struct would need to be renamed to match that style. If we were making a too-short name into a public symbol, I'd be worried about addressing that now, but I think this is purely about style and can wait. -Peff