Johannes Schindelin wrote:
+ case "$INTERACTIVE" in
+ t)
+ git_editor "$TODO" || die "Could not execute editor"
+ ;;
+ esac
Would that not be easier to read as
test t = "$INTERACTIVE" &&
git_editor "$TODO" || die "Could not execute editor"
Written like that, it would die every time $INTERACTIVE isn't "t". You'd need
curly braces around
git_editor "$TODO" || die "Could not execute editor"
--
Andreas Ericsson andreas.ericsson@xxxxxx
OP5 AB www.op5.se
Tel: +46 8-230225 Fax: +46 8-230231
-
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html