Phillip Wood <phillip.wood123@xxxxxxxxx> writes: >>> I noticed there is also `clear()` used in some places. Should we also >>> mention that we don't recommend using `clear()` WRT freeing memory? >> In any case I think we should decide on eithe using `clear()` or >> using >> `release()` for consistency's sake. Which of both we use I don't quite >> care, but the following very shoddy analysis clearly favors `release()`: >> $ git grep '_clear(' | wc -l >> 844 >> $ git grep '_release(' | wc -l >> 2126 > > I think a fairer comparison would be to look at function declarations, > not all the call sites. > > $ { git grep 'void [a-z_]*_release(' '*.h' > git grep 'static void [a-z_]*_release(' '*.c' > } | wc -l > 47 > $ { git grep 'void [a-z_]*_clear(' '*.h' > git grep 'static void [a-z_]*_clear(' '*.c' > } | wc -l > 58 > > So we have more _clear() functions than _release() functions. I think > there may sometimes be a semantic difference between _clear() and > _release() as well where some _clear() functions zero out the struct > after freeing the members. > > Thanks for working on this it will be a useful addition to our coding > guidelines Thanks for doing a more thorough study of the current codebase. I tend to agree that the number of actual _clear() functions matter a lot more than how many callsites call _clear(), and it would make sense to standardise on it. If everything else being equal, it does not matter which one we pick, but it rarely happens that everything else is equal. - "release" is a bit more cumbersome to type and read than "clear". - "clear" at least to me says more about the state of the thing after it got cleared (e.g., I would expect it would be filled with NUL bytes) - "release" places a lot more stress on what happens to the things that were contained before the release takes place. For example, upon either "clear" or "release", I would expect everything pointed by elements in an array member of the struct, and the array pointed at by the member, are free'd when we are "clearing/releasing" a strvec. But I may not care what is left in it after "release". It can be left to hold all the bytes the struct had before "release" got called, as anybody who called the function are not supposed to look at the struct again anyway. But we may choose not to have such a variant and always clear the struct after releasing resources it held, just for good hygiene. So in short, I would consider that "clear = release + init". If we want to have both "clear" and "release" and have them distinct meaning, that is fine. If we want to simplify and do without "just release and leave them dirty" variant, then we need only one name for it, and I do not mind if we called it "release", even though I would think "clear" is a better name for the action that behaves as if "init" was done at the end to make it reusable. Thanks.