What's cooking in git.git (Jul 2024, #03; Thu, 11)

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Here are the topics that have been cooking in my tree.  Commits
prefixed with '+' are in 'next' (being in 'next' is a sign that a
topic is stable enough to be used and are candidate to be in a
future release).  Commits prefixed with '-' are only in 'seen', and
aren't considered "accepted" at all and may be annotated with an URL
to a message that raises issues but they are no means exhaustive.  A
topic without enough support may be discarded after a long period of
no activity (of course they can be resubmit when new interests
arise).

Copies of the source code to Git live in many repositories, and the
following is a list of the ones I push into or their mirrors.  Some
repositories have only a subset of branches.

With maint, master, next, seen, todo:

	git://git.kernel.org/pub/scm/git/git.git/
	git://repo.or.cz/alt-git.git/
	https://kernel.googlesource.com/pub/scm/git/git/
	https://github.com/git/git/
	https://gitlab.com/git-scm/git/

With all the integration branches and topics broken out:

	https://github.com/gitster/git/

Even though the preformatted documentation in HTML and man format
are not sources, they are published in these repositories for
convenience (replace "htmldocs" with "manpages" for the manual
pages):

	git://git.kernel.org/pub/scm/git/git-htmldocs.git/
	https://github.com/gitster/git-htmldocs.git/

Release tarballs are available at:

	https://www.kernel.org/pub/software/scm/git/

--------------------------------------------------
[New Topics]

* jc/where-is-bash-for-ci (2024-07-08) 1 commit
  (merged to 'next' on 2024-07-09 at 14b00e672e)
 + ci: unify bash calling convention

 Shell script clean-up.

 Will merge to 'master'.
 source: <xmqqwmlvcx9g.fsf_-_@gitster.g>


* kn/push-empty-fix (2024-07-09) 1 commit
 - builtin/push: call set_refspecs after validating remote

 "git push '' HEAD:there" used to hit a BUG(); it has been corrected
 to die with "fatal: bad repository ''".

 Expecting a reroll.
 cf. <xmqq4j8yflrq.fsf@gitster.g>
 source: <20240709144931.1146528-1-karthik.188@xxxxxxxxx>


* ad/merge-with-diff-algorithm (2024-07-10) 1 commit
  (merged to 'next' on 2024-07-11 at 2a221341d9)
 + merge-recursive: honor diff.algorithm

 Many Porcelain commands that internally use the merge machinery
 were taught to consistently honor the diff.algorithm configuration.

 Will merge to 'master'.
 source: <pull.1743.v2.git.git.1720551701648.gitgitgadget@xxxxxxxxx>


* jc/http-cookiefile (2024-07-09) 1 commit
  (merged to 'next' on 2024-07-11 at abdd5711d2)
 + http.c: cookie file tightening

 The http.cookieFile and http.saveCookies configuration variables
 have a few values that need to be avoided, which are now ignored
 with warning messages.

 Will merge to 'master'.
 source: <xmqqed82cgmj.fsf@gitster.g>


* jk/add-patch-with-suppress-blank-empty (2024-07-10) 1 commit
  (merged to 'next' on 2024-07-11 at cec8ebb668)
 + add-patch: handle splitting hunks with diff.suppressBlankEmpty

 When the diff.suppressBlankEmpty configuration variable is set,
 "git add -p" failed to process a patch with an unmodified empty
 line, which has been corrected.

 Will merge to 'master'.
 source: <20240710093610.GA2076910@xxxxxxxxxxxxxxxxxxxxxxx>

--------------------------------------------------
[Stalled]

* cp/unit-test-reftable-tree (2024-06-13) 5 commits
 - t-reftable-tree: improve the test for infix_walk()
 - t-reftable-tree: add test for non-existent key
 - t-reftable-tree: split test_tree() into two sub-test functions
 - t: move reftable/tree_test.c to the unit testing framework
 - reftable: remove unnecessary curly braces in reftable/tree.c

 A test in reftable library has been rewritten using the unit test
 framework.

 Needs review.
 source: <20240612130217.8877-1-chandrapratap3519@xxxxxxxxx>


* sj/ref-fsck (2024-07-10) 10 commits
 - fsck: add ref content check for files backend
 - fsck: add ref name check for files backend
 - files-backend: add unified interface for refs scanning
 - builtin/fsck: add `git-refs verify` child process
 - builtin/refs: add verify subcommand and verbose_refs for "fsck_options"
 - refs: set up ref consistency check infrastructure
 - fsck: add refs-related error report function
 - fsck: add a unified interface for reporting fsck messages
 - fsck: rename objects-related fsck error functions
 - fsck: rename "skiplist" to "skip_oids"

 "git fsck" infrastructure has been taught to also check the sanity
 of the ref database, in addition to the object database.

 Needs review.
 source: <Zo6eJi8BePrQxTQV@ArchLinux>


* cp/unit-test-reftable-pq (2024-06-14) 7 commits
 - t-reftable-pq: add tests for merged_iter_pqueue_top()
 - t-reftable-pq: add test for index based comparison
 - t-reftable-pq: make merged_iter_pqueue_check() callable by reference
 - t-reftable-pq: make merged_iter_pqueue_check() static
 - t: move reftable/pq_test.c to the unit testing framework
 - reftable: change the type of array indices to 'size_t' in reftable/pq.c
 - reftable: remove unncessary curly braces in reftable/pq.c

 The tests for "pq" part of reftable library got rewritten to use
 the unit test framework.

 Needs review.
 source: <20240614095136.12052-1-chandrapratap3519@xxxxxxxxx>


* tb/incremental-midx-part-1 (2024-06-07) 19 commits
 - midx: implement support for writing incremental MIDX chains
 - t/t5313-pack-bounds-checks.sh: prepare for sub-directories
 - t: retire 'GIT_TEST_MULTI_PACK_INDEX_WRITE_BITMAP'
 - midx: implement verification support for incremental MIDXs
 - midx: support reading incremental MIDX chains
 - midx: teach `midx_fanout_add_midx_fanout()` about incremental MIDXs
 - midx: teach `midx_preferred_pack()` about incremental MIDXs
 - midx: teach `midx_contains_pack()` about incremental MIDXs
 - midx: remove unused `midx_locate_pack()`
 - midx: teach `fill_midx_entry()` about incremental MIDXs
 - midx: teach `nth_midxed_offset()` about incremental MIDXs
 - midx: teach `bsearch_midx()` about incremental MIDXs
 - midx: introduce `bsearch_one_midx()`
 - midx: teach `nth_bitmapped_pack()` about incremental MIDXs
 - midx: teach `nth_midxed_object_oid()` about incremental MIDXs
 - midx: teach `prepare_midx_pack()` about incremental MIDXs
 - midx: teach `nth_midxed_pack_int_id()` about incremental MIDXs
 - midx: add new fields for incremental MIDX chains
 - Documentation: describe incremental MIDX format

 Incremental updates of multi-pack index files.

 Needs review.
 source: <cover.1717715060.git.me@xxxxxxxxxxxx>


* vd/mktree (2024-06-20) 17 commits
 - mktree: remove entries when mode is 0
 - mktree: allow deeper paths in input
 - mktree: optionally add to an existing tree
 - mktree: add directory-file conflict hashmap
 - mktree: use iterator struct to add tree entries to index
 - mktree: create tree using an in-core index
 - mktree: overwrite duplicate entries
 - mktree: validate paths more carefully
 - mktree: add a --literally option
 - mktree.c: do not fail on mismatched submodule type
 - mktree: use read_index_info to read stdin lines
 - index-info.c: parse object type in provided in read_index_info
 - index-info.c: return unrecognized lines to caller
 - update-index: generalize 'read_index_info'
 - mktree: use non-static tree_entry array
 - mktree: rename treeent to tree_entry
 - mktree: use OPT_BOOL

 "git mktree" has been rewritten, taking advantage of the cache-tree
 API.

 Will merge to 'next'?
 source: <pull.1746.v2.git.1718834285.gitgitgadget@xxxxxxxxx>


* pp/add-parse-range-unit-test (2024-05-27) 1 commit
 - apply: add unit tests for parse_range

 A unit test for code that parses the hunk offset and length from a
 patch fragment header as been added.

 Expecting a reroll.
 cf. <b7eca313-9ea8-4132-ba1d-ed9236e07095@xxxxxxxxx>
 source: <pull.1677.v2.git.git.1716710073910.gitgitgadget@xxxxxxxxx>


* cw/git-std-lib (2024-02-28) 4 commits
 . SQUASH??? get rid of apparent debugging crufts
 . test-stdlib: show that git-std-lib is independent
 . git-std-lib: introduce Git Standard Library
 . pager: include stdint.h because uintmax_t is used

 Split libgit.a out to a separate git-std-lib tor easier reuse.

 Expecting a reroll.
 source: <cover.1696021277.git.jonathantanmy@xxxxxxxxxx>

--------------------------------------------------
[Cooking]

* jc/checkout-no-op-switch-errors (2024-07-02) 1 commit
 - checkout: special case error messages during noop switching

 "git checkout --ours" (no other arguments) complained that the
 option is incompatible with branch switching, which is technically
 correct, but found confusing by some users.  It now says that the
 user needs to give pathspec to specify what paths to checkout.

 Needs review.
 source: <xmqqikxnqzz4.fsf@gitster.g>


* jc/disable-push-nego-for-deletion (2024-07-02) 1 commit
  (merged to 'next' on 2024-07-08 at 18411fb8ac)
 + push: avoid showing false negotiation errors

 "git push" that pushes only deletion gave an unnecessary and
 harmless error message when push negotiation is configured, which
 has been corrected.

 Will merge to 'master'.
 source: <xmqqo77fr2h0.fsf@gitster.g>


* bc/gitfaq-more (2024-07-09) 4 commits
  (merged to 'next' on 2024-07-10 at eeec4009e4)
 + doc: mention that proxies must be completely transparent
 + gitfaq: add entry about syncing working trees
 + gitfaq: give advice on using eol attribute in gitattributes
 + gitfaq: add documentation on proxies

 A handful of entries are added to the GitFAQ document.

 Will merge to 'master'.
 source: <20240709233746.445860-1-sandals@xxxxxxxxxxxxxxxxxxxx>


* cp/unit-test-reftable-merged (2024-07-11) 7 commits
 - t-reftable-merged: add test for REFTABLE_FORMAT_ERROR
 - t-reftable-merged: use reftable_ref_record_equal to compare ref records
 - t-reftable-merged: add tests for reftable_merged_table_max_update_index
 - t-reftable-merged: improve the const-correctness of helper functions
 - t-reftable-merged: improve the test t_merged_single_record()
 - t: harmonize t-reftable-merged.c with coding guidelines
 - t: move reftable/merged_test.c to the unit testing framework

 Another reftable test has been ported to use the unit test framework.

 Looking good.
 source: <20240711040854.4602-1-chandrapratap3519@xxxxxxxxx>


* ds/advice-sparse-index-expansion (2024-07-08) 1 commit
  (merged to 'next' on 2024-07-09 at c821020b13)
 + advice: warn when sparse index expands

 A new warning message is issued when a command has to expand a
 sparse index to handle working tree cruft that are outside of the
 sparse checkout.

 Will merge to 'master'.
 source: <pull.1756.v2.git.1720448038745.gitgitgadget@xxxxxxxxx>


* am/gitweb-feed-use-committer-date (2024-07-07) 1 commit
  (merged to 'next' on 2024-07-08 at 65215ab842)
 + gitweb: rss/atom change published/updated date to committer date

 GitWeb update to use committer date consistently in rss/atom feeds.

 Will merge to 'master'.
 source: <20240707184813.33166-1-080ariel@xxxxxxxxx>


* rs/clang-format-updates (2024-07-06) 1 commit
  (merged to 'next' on 2024-07-08 at d2b5b41844)
 + clang-format: include kh_foreach* macros in ForEachMacros

 Custom control structures we invented more recently have been
 taught to the clang-format file.

 Will merge to 'master'.
 source: <4e7893f5-2dd9-46cf-8a64-cf780f4e1730@xxxxxx>


* rs/t-strvec-use-test-msg (2024-07-06) 1 commit
  (merged to 'next' on 2024-07-08 at c28c2553de)
 + t-strvec: use test_msg()

 Unit test clean-up.

 Will merge to 'master'.
 source: <983be396-f47c-4573-8c33-af8367f8ddbe@xxxxxx>


* tb/dev-build-pedantic-fix (2024-07-06) 1 commit
  (merged to 'next' on 2024-07-08 at 7f34cc6c5b)
 + config.mak.dev: fix typo when enabling -Wpedantic

 Developer build procedure fix.

 Will merge to 'master'.
 source: <cbc9446b1b0f2453b96aa9c0d89b9ec086a619bd.1720205457.git.me@xxxxxxxxxxxx>


* gt/unit-test-hashmap (2024-07-08) 1 commit
 - t: port helper/test-hashmap.c to unit-tests/t-hashmap.c

 An existing test of hashmap API has been rewritten with the
 unit-test framework.

 Needs review.
 source: <20240708161641.10335-2-shyamthakkar001@xxxxxxxxx>


* ri/doc-show-branch-fix (2024-07-08) 1 commit
  (merged to 'next' on 2024-07-08 at efcb154dfe)
 + doc: fix the max number of branches shown by "show-branch"

 Docfix.

 Will merge to 'master'.
 source: <pull.1757.v5.git.1720444080034.gitgitgadget@xxxxxxxxx>


* as/pathspec-h-typofix (2024-07-01) 1 commit
  (merged to 'next' on 2024-07-02 at ae7cee4189)
 + pathspec: fix typo "glossary-context.txt" -> "glossary-content.txt"

 Typofix.

 Will merge to 'master'.
 source: <20240629193137.54037-1-abhijeet.nkt@xxxxxxxxx>


* gt/unit-test-oidmap (2024-07-03) 1 commit
  (merged to 'next' on 2024-07-08 at 4e7394fc67)
 + t: migrate helper/test-oidmap.c to unit-tests/t-oidmap.c

 An existing test of oidmap API has been rewritten with the
 unit-test framework.

 Will merge to 'master'.
 source: <20240703062958.23262-2-shyamthakkar001@xxxxxxxxx>


* jk/test-body-in-here-doc (2024-07-10) 10 commits
  (merged to 'next' on 2024-07-11 at 854733cffc)
 + t/.gitattributes: ignore whitespace in chainlint expect files
 + t: convert some here-doc test bodies
 + test-lib: allow test snippets as here-docs
 + chainlint.pl: add tests for test body in heredoc
 + chainlint.pl: recognize test bodies defined via heredoc
 + chainlint.pl: check line numbers in expected output
 + chainlint.pl: force CRLF conversion when opening input files
 + chainlint.pl: do not spawn more threads than we have scripts
 + chainlint.pl: only start threads if jobs > 1
 + chainlint.pl: add test_expect_success call to test snippets

 The test framework learns to take the test body not as a single
 string but as a here-document.

 Will merge to 'master'.
 source: <20240710083416.GA2060328@xxxxxxxxxxxxxxxxxxxxxxx>


* rj/t0612-no-longer-leaks (2024-07-01) 1 commit
  (merged to 'next' on 2024-07-08 at a63b027a20)
 + t0612: mark as leak-free

 A test that no longer leaks has been marked as such.

 Will merge to 'master'.
 source: <86427b9e-9574-4e61-890a-691779a8da82@xxxxxxxxx>


* rj/t0613-no-longer-leaks (2024-07-01) 1 commit
  (merged to 'next' on 2024-07-08 at b6149c3032)
 + t0613: mark as leak-free

 A test that no longer leaks has been marked as such.

 Will merge to 'master'.
 source: <23d41343-54fd-46c6-9d78-369e8009fa0b@xxxxxxxxx>


* rj/test-sanitize-leak-log-fix (2024-07-11) 2 commits
  (merged to 'next' on 2024-07-11 at 9961f42025)
 + test-lib: GIT_TEST_SANITIZE_LEAK_LOG enabled by default
  (merged to 'next' on 2024-07-08 at c7ee7d03e1)
 + test-lib: fix GIT_TEST_SANITIZE_LEAK_LOG

 Tests that use GIT_TEST_SANITIZE_LEAK_LOG feature got their exit
 status inverted, which has been corrected.

 Will merge to 'master'.
 source: <f4ae6e2a-218a-419c-b6c4-59a08be247a0@xxxxxxxxx>
 source: <fe8cd0d1-e451-43d0-b033-11bbb6d1ed56@xxxxxxxxx>


* rs/simplify-submodule-helper-super-prefix-invocation (2024-07-01) 1 commit
  (merged to 'next' on 2024-07-02 at 06e1677920)
 + submodule--helper: use strvec_pushf() for --super-prefix

 Code clean-up.

 Will merge to 'master'.
 source: <fb79ebc4-5ecf-4257-ac2e-39f98db5649c@xxxxxx>


* rs/unit-tests-test-run (2024-07-01) 6 commits
 - t-strbuf: use TEST_RUN
 - t-strvec: use TEST_RUN
 - t-reftable-basics: use TEST_RUN
 - t-ctype: use TEST_RUN
 - unit-tests: add TEST_RUN
 - t0080: move expected output to a file

 Unit-test framework clean-up.

 Expecting a reroll.
 cf. <97390954-49bc-48c4-bab1-95be10717aca@xxxxxx>
 source: <85b6b8a9-ee5f-42ab-bcbc-49976b30ef33@xxxxxx>


* cp/unit-test-reftable-record (2024-07-02) 11 commits
  (merged to 'next' on 2024-07-08 at b534dac338)
 + t-reftable-record: add tests for reftable_log_record_compare_key()
 + t-reftable-record: add tests for reftable_ref_record_compare_name()
 + t-reftable-record: add index tests for reftable_record_is_deletion()
 + t-reftable-record: add obj tests for reftable_record_is_deletion()
 + t-reftable-record: add log tests for reftable_record_is_deletion()
 + t-reftable-record: add ref tests for reftable_record_is_deletion()
 + t-reftable-record: add comparison tests for obj records
 + t-reftable-record: add comparison tests for index records
 + t-reftable-record: add comparison tests for ref records
 + t-reftable-record: add reftable_record_cmp() tests for log records
 + t: move reftable/record_test.c to the unit testing framework

 A test in reftable library has been rewritten using the unit test
 framework.

 Will merge to 'master'.
 cf. <CAOLa=ZT_x1Kf7EopU+RbBFzX3EPU5NWx6f8L9Uw=sM0MbCXDAQ@xxxxxxxxxxxxxx>
 source: <20240702074906.5587-1-chandrapratap3519@xxxxxxxxx>


* as/describe-broken-refresh-index-fix (2024-06-26) 1 commit
  (merged to 'next' on 2024-07-08 at 2307a4a4ae)
 + describe: refresh the index when 'broken' flag is used

 "git describe --dirty --broken" forgot to refresh the index before
 seeing if there is any chang, ("git describe --dirty" correctly did
 so), which has been corrected.

 Will merge to 'master'.
 source: <20240626190801.68472-1-abhijeet.nkt@xxxxxxxxx>


* cb/send-email-sanitize-trailer-addresses (2024-07-01) 1 commit
  (merged to 'next' on 2024-07-09 at 442a99106a)
 + git-send-email: use sanitized address when reading mbox body

 Address-looking strings found on the trailer are now placed on the
 Cc: list after running through sanitize_address.

 Will merge to 'master'.
 source: <20240701090115.56957-1-csokas.bence@xxxxxxxxx>


* jk/tests-without-dns (2024-06-26) 3 commits
  (merged to 'next' on 2024-07-08 at 21af592457)
 + t/lib-bundle-uri: use local fake bundle URLs
 + t5551: do not confirm that bogus url cannot be used
 + t5553: use local url for invalid fetch

 Test suite has been taught not to unnecessarily rely on DNS failing
 a bogus external name.

 Will merge to 'master'.
 source: <20240626205355.GA1009060@xxxxxxxxxxxxxxxxxxxxxxx>


* bc/http-proactive-auth (2024-07-09) 1 commit
  (merged to 'next' on 2024-07-10 at 29b050bf0e)
 + http: allow authenticating proactively

 The http transport can now be told to send request with
 authentication material without first getting a 401 response.

 Will merge to 'master'.
 source: <20240710000155.947377-2-sandals@xxxxxxxxxxxxxxxxxxxx>


* jc/patch-id (2024-06-21) 5 commits
 - patch-id: tighten code to detect the patch header
 - patch-id: rewrite code that detects the beginning of a patch
 - patch-id: make get_one_patchid() more extensible
 - patch-id: call flush_current_id() only when needed
 - t4204: patch-id supports various input format

 The patch parser in "git patch-id" has been tightened to avoid
 getting confused by lines that look like a patch header in the log
 message.

 Needs review.
 source: <20240621231826.3280338-1-gitster@xxxxxxxxx>


* en/ort-inner-merge-error-fix (2024-07-06) 8 commits
  (merged to 'next' on 2024-07-09 at 74bdae0b3b)
 + merge-ort: fix missing early return
  (merged to 'next' on 2024-06-28 at a85fe270e6)
 + merge-ort: convert more error() cases to path_msg()
 + merge-ort: upon merge abort, only show messages causing the abort
 + merge-ort: loosen commented requirements
 + merge-ort: clearer propagation of failure-to-function from merge_submodule
 + merge-ort: fix type of local 'clean' var in handle_content_merge ()
 + merge-ort: maintain expected invariant for priv member
 + merge-ort: extract handling of priv member into reusable function

 The "ort" merge backend saw one bugfix for a crash that happens
 when inner merge gets killed, and assorted code clean-ups.

 Will merge to 'master'.
 source: <pull.1748.v2.git.1718766019.gitgitgadget@xxxxxxxxx>




[Index of Archives]     [Linux Kernel Development]     [Gcc Help]     [IETF Annouce]     [DCCP]     [Netdev]     [Networking]     [Security]     [V4L]     [Bugtraq]     [Yosemite]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Linux SCSI]     [Fedora Users]

  Powered by Linux