Pierre Habouzit schrieb: > { > const char *percent = strchrnul(fmt, '%'); > while (*percent) { > strbuf_add(sb, fmt, percent - fmt); > fmt = percent + 1; > > /* do your stuff */ > > percent = strchrnul(fmt, '%'); > } > strbuf_add(sb, fmt, percent - fmt); > } > > > Which would require strchrnul, but it's trivial compat/ material for sure. Grepping through the source I see several places that can be simplified by converting them to strchrnul(), so I think introducing this GNU extension is a good idea in any case. Using strchr()/strchrnul() instead of strbuf_addch()'ing is sensible, of course. I don't like the duplicate code in your sketch above, though. I'll try to look into it later today. Thanks! René - To unsubscribe from this list: send the line "unsubscribe git" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html