Jeff King <peff@xxxxxxxx> writes: > I.e. either: > > for i in $(test_seq 10000) > do > echo "create refs/heads/branch-$i HEAD" > done > > or: > > i=0 > while test $i -lt 10000 > do > echo "create refs/heads/branch-$i HEAD" > i=$((i+1)) > done > > I think the first one actually incurs an extra process anyway because of > the $(). The second one would not. Of course, the second one probably > needs &&-chaining and a "|| return 1" to work in our test snippet. > ... > Then you could just write: > > test_seq -f "create refs/heads/branch-%d HEAD" 0 9999 > > and I suspect there are several other spots which could be simplified as > well. > > Anyway, I don't think it is worth derailing your series for this, but > just general food for thought. Yup, I agree with everything you said. Thanks.