Dragan Simic <dsimic@xxxxxxxxxxx> writes: > Emit additional vertical whitespace after the "Send this email [y/n/...]?" > confirmation prompts, more specifically after each confirmed email is sent, > but before the subsequent messages are emitted, to make the produced output > more readable. The subsequent produced messages were bunched together with > the confirmation prompts, as visible in the sample output excerpt below, > which made discerning the outputs unnecessarily harder. > > ... > Send this email? ([y]es|[n]o|[e]dit|[q]uit|[a]ll): y > OK. Log says: > ... What comes before "send this email" prompt needs to be shown to make the argument more convincing, but with "..." there is no cue to decide if the output is hard to read. > sub send_message { > my ($recipients_ref, $to, $date, $gitversion, $cc, $ccline, $header) = gen_header(); > my @recipients = @$recipients_ref; > + my $prompt_separator = 0; > > my @sendmail_parameters = ('-i', @recipients); > my $raw_from = $sender; > @@ -1556,6 +1557,7 @@ sub send_message { > $confirm = 'never'; > $needs_separator = 1; > } > + $prompt_separator = 1; > } else { > $needs_separator = 1; > } > @@ -1665,6 +1667,7 @@ sub send_message { > $smtp->dataend() or die $smtp->message; > $smtp->code =~ /250|200/ or die sprintf(__("Failed to send %s\n"), $subject).$smtp->message; > } > + print "\n" if ($prompt_separator); "prompt separator" sounds more like a separator that separates prompts, but that is not what is going on, no? Do we even need that new varible in the first place? I am wondering if you can just do the print "\n" right where you assign to that variable. When $confirm is set to 'never', you have both $needs_separtor and $prompt_separator set. Would it mean you'd have two extra blank lines for that message? All these questions you should have been able to avoided with a bit more helpful explanation in the proposed log message, I hope. Thanks. > if ($quiet) { > printf($dry_run ? __("Dry-Sent %s\n") : __("Sent %s\n"), $subject); > } else {