Re: [RFC][PATCH] t-prio-queue: simplify using compound literals

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Tue, Apr 02, 2024 at 08:30:31PM +0200, René Scharfe wrote:

> Test names like "basic" are mentioned seven times in the code (ignoring
> case): Twice when defining the input and result macros, thrice when
> defining the test function, and twice again when calling it.  Reduce
> that to a single time by using compound literals to pass the input and
> result arrays via TEST_INPUT to test_prio_queue().
> 
> Signed-off-by: René Scharfe <l.s.r@xxxxxx>
> ---
> C99 added compound literals.  Are we ready to use them?
> 
> Test definitions become more compact, but look busier due to the added
> punctuation.  We could hide some of it with a sugary macro like this:
> #define INT_ARRAY(...) ((int []){ __VA_ARGS__ })

FWIW, I think the result is way more readable than the original, even
without the INT_ARRAY (which I'm not sure adds much). I don't have a
strong opinion on compound literals in general, but if we did allow
them, we could clean up the horrible non-reentrant DATE_MODE().

-Peff




[Index of Archives]     [Linux Kernel Development]     [Gcc Help]     [IETF Annouce]     [DCCP]     [Netdev]     [Networking]     [Security]     [V4L]     [Bugtraq]     [Yosemite]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Linux SCSI]     [Fedora Users]

  Powered by Linux