Christian Couder <christian.couder@xxxxxxxxx> writes: > In a following commit, we will need to add all the oids from a set into > another set. In "list-objects-filter.c", there is already a static > function called add_all() to do that. > > Let's rename this function oidset_insert_from_set() and move it into > oidset.{c,h} to make it generally available. > > While at it, let's remove a useless `!= NULL`. Makes sense. My initial reaction was that copying underlying bits may even be more efficient, but that was only because silly-me did not realize that dst can be non-empty when the operation starts. The name of the function is not "copy oidset" but "insert from set" that makes it crystal clear what is going on. Good.