On Fri, Jan 12, 2024 at 07:06:35AM +0000, Linus Arver via GitGitGadget wrote: > From: Linus Arver <linusa@xxxxxxxxxx> > > In d70a9eb611 (strvec: rename struct fields, 2020-07-28), we renamed the > "argv" member to "v". In the same patch we also did the following rename > in strvec.c: > > -void strvec_pushv(struct strvec *array, const char **argv) > +void strvec_pushv(struct strvec *array, const char **items) > > and it appears that this s/argv/items operation was erroneously applied > to strvec.h. > > Rename "items" to "v". Good catch. The source of the problem is that the patch originally used "items" in the struct, too, but after review we settled on the more concise "v". I'd almost certainly have then flipped the name in the struct definition and relied on the compiler to help find the fallout. But of course it doesn't look in comments. :) As you note, we still call use "items" for the vector passed in to pushv. I think that is OK, and there is no real need to use the terse "v" there (it is also purely internal; the declaration in strvec.h does not name it at all). So this patch looks great to me. Thanks! -Peff