Re: [PATCH 2/3] Revert "send-email: extract email-parsing code into a subroutine"

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Fri, Oct 20, 2023 at 06:13:10AM -0400, Jeff King wrote:
But one thing that gives me pause is that the neither before or after
this patch do we handle continuation lines like:

 Subject: this is the beginning
   and this is more subject

And it would probably be a lot easier to add when storing the headers in
a hash (it's not impossible to do it the other way, but you basically
have to delay processing each line with a small state machine).

that seems like a rather significant point, doesn't it?

So another option is to just fix the individual bugs separately.

... so that seems preferable to me, given that the necessary fixes seem rather trivial.

I guess "readable" is up for debate here, but I find the inline handling
a lot easier to follow

any particular reason for that?

(and it's half as many lines; most of the diffstat is the new tests).

-	if ($parsed_email{'From'}) {
-		$sender = delete($parsed_email{'From'});
-	}

this verbosity could be cut down somewhat using just

  $sender = delete($parsed_email{'From'});

and if the value can be pre-set and needs to be preserved,

  $sender = delete($parsed_email{'From'}) // $sender;

but this seems kind of counter-productive legibility-wise.

regards




[Index of Archives]     [Linux Kernel Development]     [Gcc Help]     [IETF Annouce]     [DCCP]     [Netdev]     [Networking]     [Security]     [V4L]     [Bugtraq]     [Yosemite]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Linux SCSI]     [Fedora Users]

  Powered by Linux