Bcc: Subject: Re: [PATCH] t/t7601: Modernize test scripts using functions Reply-To: In-Reply-To: <20231016152113.135970-1-anonolitunya@xxxxxxxxx> On Mon, Oct 16, 2023 at 06:21:00PM +0300, Dorcas AnonoLitunya wrote: > The test script is currently using the command format 'test -f' to > check for existence or absence of files. > > Replace it with new helper functions following the format > 'test_path_is_file'. > > Consequently, the patch also replaces the inverse command '! test -f' or > 'test ! -f' with new helper function following the format > 'test_path_is_missing' > > This adjustment using helper functions makes the code more readable and > easier to understand. > > Signed-off-by: Dorcas AnonoLitunya <anonolitunya@xxxxxxxxx> > --- > t/t7601-merge-pull-config.sh | 24 ++++++++++++------------ > 1 file changed, 12 insertions(+), 12 deletions(-) > > diff --git a/t/t7601-merge-pull-config.sh b/t/t7601-merge-pull-config.sh > index bd238d89b0..e08767df66 100755 > --- a/t/t7601-merge-pull-config.sh > +++ b/t/t7601-merge-pull-config.sh > @@ -349,13 +349,13 @@ test_expect_success 'Cannot rebase with multiple heads' ' > > test_expect_success 'merge c1 with c2' ' > git reset --hard c1 && > - test -f c0.c && > - test -f c1.c && > - test ! -f c2.c && > - test ! -f c3.c && > + test_path_is_file c0.c && > + test_path_is_file c1.c && > + test_path_is_missing c2.c && > + test_path_is_missing c3.c && > git merge c2 && > - test -f c1.c && > - test -f c2.c > + test_path_is_file c1.c && > + test_path_is_file c2.c > ' > > test_expect_success 'fast-forward pull succeeds with "true" in pull.ff' ' > @@ -411,8 +411,8 @@ test_expect_success 'merge c1 with c2 (ours in pull.twohead)' ' > git reset --hard c1 && > git config pull.twohead ours && > git merge c2 && > - test -f c1.c && > - ! test -f c2.c > + test_path_is_file c1.c && > + test_path_is_missing c2.c > ' > > test_expect_success 'merge c1 with c2 and c3 (recursive in pull.octopus)' ' > @@ -431,10 +431,10 @@ test_expect_success 'merge c1 with c2 and c3 (recursive and octopus in pull.octo > test "$(git rev-parse c2)" = "$(git rev-parse HEAD^2)" && > test "$(git rev-parse c3)" = "$(git rev-parse HEAD^3)" && > git diff --exit-code && > - test -f c0.c && > - test -f c1.c && > - test -f c2.c && > - test -f c3.c > + test_path_is_file c0.c && > + test_path_is_file c1.c && > + test_path_is_file c2.c && > + test_path_is_file c3.c > ' > > conflict_count() > -- > 2.42.0.345.gaab89be2eb > Please ignore this version as I had not indicated Outreachy in the subject header. Thanks.