On Thu, Oct 05, 2023 at 01:51:42PM -0400, Taylor Blau wrote: > @@ -1033,11 +1033,11 @@ struct write_commit_graph_context { > uint64_t progress_cnt; > > char *base_graph_name; > - int num_commit_graphs_before; > - int num_commit_graphs_after; > - char **commit_graph_filenames_before; > - char **commit_graph_filenames_after; > - char **commit_graph_hash_after; > + struct { > + size_t nr; > + char **fname; > + char **hash; > + } graphs_before, graphs_after; > uint32_t new_num_commits_in_base; > struct commit_graph *new_base_graph; > --- >8 --- > > ...making the corresponding changes throughout the rest of the file. But > that is definitely out of scope here, and could easily be left for > another day. I agree that it would make things a bit more readable, but there currently is no "hash_before". So they're not quite symmetric. -Peff