Re: [PATCH v4 5/8] fetch: introduce `display_format` enum

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Patrick Steinhardt <ps@xxxxxx> writes:

> We currently have two different display formats in git-fetch(1) with the
> "full" and "compact" formats. This is tracked with a boolean value that
> simply denotes whether the display format is supposed to be compacted
> or not. This works reasonably well while there are only two formats, but
> we're about to introduce another format that will make this a bit more
> awkward to use.
>
> Introduce a `enum display_format` that is more readily extensible.

Makes sense.

> +enum display_format {
> +	DISPLAY_FORMAT_UNKNOWN = 0,
> +	DISPLAY_FORMAT_FULL,
> +	DISPLAY_FORMAT_COMPACT,
> +};
>
>  struct display_state {
>  	struct strbuf buf;
>  
>  	int refcol_width;
> -	int compact_format;
> +	enum display_format format;

OK.  Preparatory conversion without adding anything new.

> @@ -809,31 +814,42 @@ static void display_state_init(struct display_state *display_state, struct ref *
>  
>  	git_config_get_string_tmp("fetch.output", &format);
>  	if (!strcasecmp(format, "full"))
> -		display_state->compact_format = 0;
> +		display_state->format = DISPLAY_FORMAT_FULL;
>  	else if (!strcasecmp(format, "compact"))
> -		display_state->compact_format = 1;
> +		display_state->format = DISPLAY_FORMAT_COMPACT;
>  	else
>  		die(_("invalid value for '%s': '%s'"),
>  		    "fetch.output", format);

Naturally.

> -	display_state->refcol_width = 10;
> -	for (rm = ref_map; rm; rm = rm->next) {
> -		int width;
> +	switch (display_state->format) {
> +	case DISPLAY_FORMAT_FULL:
> +	case DISPLAY_FORMAT_COMPACT: {
> +		struct ref *rm;
>  
> -		if (rm->status == REF_STATUS_REJECT_SHALLOW ||
> -		    !rm->peer_ref ||
> -		    !strcmp(rm->name, "HEAD"))
> -			continue;
> +		display_state->refcol_width = 10;
> +		for (rm = ref_map; rm; rm = rm->next) {
> +			int width;
>  
> -		width = refcol_width(rm, display_state->compact_format);
> +			if (rm->status == REF_STATUS_REJECT_SHALLOW ||
> +			    !rm->peer_ref ||
> +			    !strcmp(rm->name, "HEAD"))
> +				continue;
>  
> -		/*
> -		 * Not precise calculation for compact mode because '*' can
> -		 * appear on the left hand side of '->' and shrink the column
> -		 * back.
> -		 */
> -		if (display_state->refcol_width < width)
> -			display_state->refcol_width = width;
> +			width = refcol_width(rm, display_state->format == DISPLAY_FORMAT_COMPACT);
> +
> +			/*
> +			 * Not precise calculation for compact mode because '*' can
> +			 * appear on the left hand side of '->' and shrink the column
> +			 * back.
> +			 */
> +			if (display_state->refcol_width < width)
> +				display_state->refcol_width = width;
> +		}
> +
> +		break;
> +	}
> +	default:
> +		BUG("unexpected display format %d", display_state->format);
>  	}

Due to reindentation, the patch is noisier than what it does (which
should be "nothing, other than allowing another value in the .format
member").

It makes me wonder if it would make it easier to read to move the
bulk of this code to a helper function.  If we are to give a name to
what is being done in the above hunk, what would it be?  It computes
display->refcol_width in which all records would fit, but presumably
if we are to add more things to be shown per ref and align them in a
simlar way, we would compute widths for these other things there as
well.  Perhaps compute_display_alignment() or somesuch?




[Index of Archives]     [Linux Kernel Development]     [Gcc Help]     [IETF Annouce]     [DCCP]     [Netdev]     [Networking]     [Security]     [V4L]     [Bugtraq]     [Yosemite]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Linux SCSI]     [Fedora Users]

  Powered by Linux