Re: [PATCH 3/8] fetch: fix missing from-reference when fetching HEAD:foo

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Rearranging the lines slightly,

Patrick Steinhardt <ps@xxxxxx> writes:

> When displaying reference updates, we print a line that looks similar to
> the following:
>
> ```
>  * branch               master          -> master
> ```
>
> The "branch" bit changes depending on what kind of reference we're
> updating, while both of the right-hand references are computed by
> stripping well-known prefixes like "refs/heads/" or "refs/tags".
>
> [...]
>                   we also use this value to display reference updates.
> And while the call to `display_ref_update()` correctly figures out that
> we meant "HEAD" when `what` is empty, the call to `update_local_ref()`
> doesn't. `update_local_ref()` will then call `display_ref_update()` with
> the empty string and cause the following broken output:
>
> ```
> $ git fetch --dry-run origin HEAD:foo
> From https://github.com/git/git
>  * [new ref]                          -> foo
> ```
>
> [...]
>
> Fix this bug by instead unconditionally passing the full reference name
> to `display_ref_update()` which learns to call `prettify_refname()` on
> it. This does fix the above bug and is otherwise functionally the same
> as `prettify_refname()` would only ever strip the well-known prefixes
> just as intended. So at the same time, this also simplifies the code a
> bit.


The bug fix is obviously good. I'm surprised we hadn't caught this
sooner.

As a nitpicky comment, the commit message goes into a lot of detail,
which makes it tricky to read on its own (though the level of detail
makes it easy to match to the diff, making the diff quite easy to
follow). I would have found this easier to read by summarizing the
high-level mental model before diving into the background, e.g.


  store_updated_refs() parses the remote ref name to create a 'note' to
  write to FETCH_HEAD. This note is usually the prettified ref name, so
  it is used to diplay ref updates (display_ref_update()). But if the
  remote ref is HEAD, the note is the empty string [insert bug
  description]. Instead, use the note only as a note and have
  display_ref_update() prettify the ref name itself...

> diff --git a/builtin/fetch.c b/builtin/fetch.c
> index c310d89878..7c64f0c562 100644
> --- a/builtin/fetch.c
> +++ b/builtin/fetch.c
> @@ -918,12 +918,14 @@ static void display_ref_update(struct display_state *display_state, char code,
>  	}
>  
>  	width = (summary_width + strlen(summary) - gettext_width(summary));
> +	remote = prettify_refname(remote);
> +	local = prettify_refname(local);
>  
>  	strbuf_addf(&display_state->buf, " %c %-*s ", code, width, summary);
>  	if (!display_state->compact_format)
> -		print_remote_to_local(display_state, remote, prettify_refname(local));
> +		print_remote_to_local(display_state, remote, local);
>  	else
> -		print_compact(display_state, remote, prettify_refname(local));
> +		print_compact(display_state, remote, local);
>  	if (error)
>  		strbuf_addf(&display_state->buf, "  (%s)", error);
>  	strbuf_addch(&display_state->buf, '\n');

As expected, we now prettify the name isntead of trusting the 'note'
that came in the parameter...

> @@ -934,7 +936,7 @@ static void display_ref_update(struct display_state *display_state, char code,
>  static int update_local_ref(struct ref *ref,
>  			    struct ref_transaction *transaction,
>  			    struct display_state *display_state,
> -			    const char *remote, const struct ref *remote_ref,
> +			    const struct ref *remote_ref,
>  			    int summary_width)
>  {
>  	struct commit *current = NULL, *updated;
> @@ -946,7 +948,7 @@ static int update_local_ref(struct ref *ref,
>  	if (oideq(&ref->old_oid, &ref->new_oid)) {
>  		if (verbosity > 0)
>  			display_ref_update(display_state, '=', _("[up to date]"), NULL,
> -					   remote, ref->name, summary_width);
> +					   remote_ref->name, ref->name, summary_width);
>  		return 0;
>  	}
>  
> @@ -959,7 +961,7 @@ static int update_local_ref(struct ref *ref,
>  		 */
>  		display_ref_update(display_state, '!', _("[rejected]"),
>  				   _("can't fetch into checked-out branch"),
> -				   remote, ref->name, summary_width);
> +				   remote_ref->name, ref->name, summary_width);
>  		return 1;
>  	}
>  
> @@ -970,12 +972,12 @@ static int update_local_ref(struct ref *ref,
>  			r = s_update_ref("updating tag", ref, transaction, 0);
>  			display_ref_update(display_state, r ? '!' : 't', _("[tag update]"),
>  					   r ? _("unable to update local ref") : NULL,
> -					   remote, ref->name, summary_width);
> +					   remote_ref->name, ref->name, summary_width);
>  			return r;
>  		} else {
>  			display_ref_update(display_state, '!', _("[rejected]"),
>  					   _("would clobber existing tag"),
> -					   remote, ref->name, summary_width);
> +					   remote_ref->name, ref->name, summary_width);
>  			return 1;
>  		}
>  	}
> @@ -1008,7 +1010,7 @@ static int update_local_ref(struct ref *ref,
>  		r = s_update_ref(msg, ref, transaction, 0);
>  		display_ref_update(display_state, r ? '!' : '*', what,
>  				   r ? _("unable to update local ref") : NULL,
> -				   remote, ref->name, summary_width);
> +				   remote_ref->name, ref->name, summary_width);
>  		return r;
>  	}
>  
> @@ -1030,7 +1032,7 @@ static int update_local_ref(struct ref *ref,
>  		r = s_update_ref("fast-forward", ref, transaction, 1);
>  		display_ref_update(display_state, r ? '!' : ' ', quickref.buf,
>  				   r ? _("unable to update local ref") : NULL,
> -				   remote, ref->name, summary_width);
> +				   remote_ref->name, ref->name, summary_width);
>  		strbuf_release(&quickref);
>  		return r;
>  	} else if (force || ref->force) {
> @@ -1042,12 +1044,12 @@ static int update_local_ref(struct ref *ref,
>  		r = s_update_ref("forced-update", ref, transaction, 1);
>  		display_ref_update(display_state, r ? '!' : '+', quickref.buf,
>  				   r ? _("unable to update local ref") : _("forced update"),
> -				   remote, ref->name, summary_width);
> +				   remote_ref->name, ref->name, summary_width);
>  		strbuf_release(&quickref);
>  		return r;
>  	} else {
>  		display_ref_update(display_state, '!', _("[rejected]"), _("non-fast-forward"),
> -				   remote, ref->name, summary_width);
> +				   remote_ref->name, ref->name, summary_width);
>  		return 1;
>  	}
>  }

...

> @@ -1277,7 +1278,7 @@ static int store_updated_refs(struct display_state *display_state,
>  					  display_state->url_len);
>  
>  			if (ref) {
> -				rc |= update_local_ref(ref, transaction, display_state, what,
> +				rc |= update_local_ref(ref, transaction, display_state,
>  						       rm, summary_width);
>  				free(ref);
>  			} else if (write_fetch_head || dry_run) {
> @@ -1288,7 +1289,7 @@ static int store_updated_refs(struct display_state *display_state,
>  				 */
>  				display_ref_update(display_state, '*',
>  						   *kind ? kind : "branch", NULL,
> -						   *what ? what : "HEAD",
> +						   rm->name,
>  						   "FETCH_HEAD", summary_width);
>  			}
>  		}

and we stop passing the 'note' as a parameter. Looks good.

> @@ -1252,14 +1254,13 @@ static int store_updated_refs(struct display_state *display_state,
>  			if (!strcmp(rm->name, "HEAD")) {
>  				kind = "";
>  				what = "";
> -			}
> -			else if (skip_prefix(rm->name, "refs/heads/", &what))
> +			} else if (skip_prefix(rm->name, "refs/heads/", &what)) {
>  				kind = "branch";
> -			else if (skip_prefix(rm->name, "refs/tags/", &what))
> +			} else if (skip_prefix(rm->name, "refs/tags/", &what)) {
>  				kind = "tag";
> -			else if (skip_prefix(rm->name, "refs/remotes/", &what))
> +			} else if (skip_prefix(rm->name, "refs/remotes/", &what)) {
>  				kind = "remote-tracking branch";
> -			else {
> +			} else {
>  				kind = "";
>  				what = rm->name;
>  			}

I really appreciate that this makes the patch easier to read. I don't
really appreciate this sort of churn, but it _is_ following
CodingGuidelines:

	- When there are multiple arms to a conditional and some of them
	  require braces, enclose even a single line block in braces for
	  consistency. E.g.:

		if (foo) {
			doit();
		} else {
			one();
			two();
			three();
		}

(I initialy thought it wasn't. Thanks to other Review Club participants
for pointing this out).

> diff --git a/t/t5574-fetch-output.sh b/t/t5574-fetch-output.sh
> index 0e45c27007..55f0f05b6a 100755
> --- a/t/t5574-fetch-output.sh
> +++ b/t/t5574-fetch-output.sh
> @@ -54,6 +54,25 @@ test_expect_success 'fetch compact output' '
>  	test_cmp expect actual
>  '
>  
> +test_expect_success 'fetch output with HEAD and --dry-run' '

The commit message and diff didn't imply that this is a --dry-run only
bug. I tested locally, and it seems to reproduce without --dry-run too,
so I think we should drop "--dry-run" from this test name. In a later
patch, you also add a test for porcelain output with --dry-run, but
since this test seems designed for just this bug, I think we can drop
the later test.



[Index of Archives]     [Linux Kernel Development]     [Gcc Help]     [IETF Annouce]     [DCCP]     [Netdev]     [Networking]     [Security]     [V4L]     [Bugtraq]     [Yosemite]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Linux SCSI]     [Fedora Users]

  Powered by Linux