On Mon, Apr 17, 2023 at 04:54:39PM -0400, Taylor Blau wrote: > for argv in \ > + "gc" \ > "gc --cruft" \ > "-c gc.cruftPacks=true gc" \ > - "-c gc.cruftPacks=false gc --cruft" \ > - "-c feature.experimental=true gc" \ > - "-c gc.cruftPacks=true -c feature.experimental=false gc" > + "-c gc.cruftPacks=false gc --cruft" > do Oh good. I was a little sad to see the increase in the size of this loop in the earlier patches, so now reducing the number of combinations is a welcome change. The set you have here looks fine, though isn't "gc --cruft" redundant with "gc" now? > @@ -246,9 +245,7 @@ done > for argv in \ > "gc --no-cruft" \ > "-c gc.cruftPacks=false gc" \ > - "-c gc.cruftPacks=true gc --no-cruft" \ > - "-c feature.expiremental=true -c gc.cruftPacks=false gc" \ > - "-c feature.experimental=false gc" > + "-c gc.cruftPacks=true gc --no-cruft" Likewise here, "gc --no-cruft" would have been redundant with "gc" before this patch, but we did not even bother with it (so no need to remove it here!). The rest of the patch looks good, and I am quite on board with the overall goal. It's been a long time coming. :) -Peff