On 2023-01-12 11:44, Victoria Dye wrote: > Matthew John Cheetham via GitGitGadget wrote: >> From: Matthew John Cheetham <mjcheetham@xxxxxxxxxxx> >> >> Rename some of the variables and function arguments used to manage child >> processes. The existing names are esoteric; stretching an analogy too >> far to the point of being confusing to understand. >> >> Rename "firstborn" to simply "first", "newborn" to "new_cld", "blanket" >> to "current" and "cradle" to "ptr". > > Thanks for this, I agree that the new names make the code much easier to > read. > >> diff --git a/daemon.c b/daemon.c >> index ec3b407ecbc..d3e7d81de18 100644 >> --- a/daemon.c >> +++ b/daemon.c >> @@ -789,7 +789,7 @@ static int max_connections = 32; >> >> static unsigned int live_children; >> >> -static struct child *firstborn; >> +static struct child *first_child; > > minor nit: you changed "firstborn" to "first" in 'daemon-utils.c' (aligning > with the commit message), but it's "first_child" here. If you end up > re-rolling, it would be nice to make the names consistent across both files > (could be 'first', 'first_child', 'first_cld', or anything really). > Fair point. There's no technical reason to keep them named differently between the 'libified' functions, and the actual variables for the callers. I shall align these to `first_child` in the next iteration. Thanks, Matthew