On Tue, Sep 27, 2022 at 02:08:28PM +0000, Derrick Stolee via GitGitGadget wrote: > From: Derrick Stolee <derrickstolee@xxxxxxxxxx> Should the patch message be: *: relax git_config_get_value_multi() result instead of referring to git_configset_get_value_multi? > --- > builtin/submodule--helper.c | 10 ++++++++-- > submodule.c | 2 +- > t/helper/test-config.c | 4 ++-- > versioncmp.c | 8 ++++---- > 4 files changed, 15 insertions(+), 9 deletions(-) All looks good here. I did a git grep for git_config_get_value_multi() to make sure all of those spots were covered here. No comments from me, other than a little thinking aloud below on a couple of the conversions. > @@ -552,7 +553,9 @@ static int module_init(int argc, const char **argv, const char *prefix) > * If there are no path args and submodule.active is set then, > * by default, only initialize 'active' modules. > */ > - if (!argc && git_config_get_value_multi("submodule.active")) > + if (!argc && > + (active_modules = git_config_get_value_multi("submodule.active")) && > + active_modules->nr) Yuck ;-). I was going to suggest that the addition of a helper function something like: static int any_configured(const char *key) { const struct string_list *vals = git_configset_get_value_multi(key); return vals && vals->nr; } would be worthwhile for this and the below conversion, but the change at the end of this series makes it a moot point. So the temporary eye-sore is just fine. > diff --git a/t/helper/test-config.c b/t/helper/test-config.c > index 4ba9eb65606..62644dd71d7 100644 > --- a/t/helper/test-config.c > +++ b/t/helper/test-config.c > @@ -96,7 +96,7 @@ int cmd__config(int argc, const char **argv) > } > } else if (argc == 3 && !strcmp(argv[1], "get_value_multi")) { > strptr = git_config_get_value_multi(argv[2]); > - if (strptr) { > + if (strptr && strptr->nr) { > for (i = 0; i < strptr->nr; i++) { > v = strptr->items[i].string; > if (!v) Good catch. I was thinking that this whole "if" statement could have been dropped, but the goto that is hidden by the context meant that this *would* have been a behavior change otherwise. So the conversion here is appropriate. Thanks, Taylor