Re: [PATCH v5 1/5] hiderefs: add hide-refs hook to hide refs dynamically

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 




> On Sep 14, 2022, at 01:01, Junio C Hamano <gitster@xxxxxxxxx> wrote:
> 
>> Gerrit is implemented by JGit and is known as a centralized workflow system
>> which supports reference-level access control for repository. If we choose
>> to work in centralized workflow like what Gerrit provided, reference-level
>> access control is needed and we might add a reference filter hook
>> `hide-refs` to hide the private data.
> 
> Please rewrite the above so that it does not sound like "Gerrit
> supports it, there are tons of users of Gerrit, we must support it,
> too".  If this feature is meaningful for us, even if Gerrit folks
> were deprecating and planning to remove the support of it, we would
> add it.  If it is not, even if Gerrit folks support it, we wouldn't.

Hi Junio, thanks for your advice here, I cannot agree with you more, I will do it.

> 
>> +
>> +		/*
>> +		 * the prefix 'hook:' means that the matched refs will be
>> +		 * checked by the hide-refs hook dynamically, we need to put
>> +		 * the 'ref' string to the hook_hide_refs list
>> +		 */
> 
> I am not sure if this deserves a five-line comment.  We didn't need
> to have a comment that says "value without hook: means the matched
> refs will be hidden and we need to remember them in the hide_refs
> string_list" for over 10 years after all.

Agree, and I will remove them.

> 
>> +		if (skip_prefix(value, "hook:", &value)) {
>> +			if (!strlen(value))
>> +				return error(_("missing value for '%s' after hook option"), var);
> 
> I am not sure it is a good idea to special case an empty string,
> especially here at this point in the code flow.  There would be
> strings that cannot be a refname prefix (e.g. "foo..bar") and such a
> check is better done at the place where the accumuldated list of ref
> patterns are actually used.  If you are using prefix match, a value
> of an empty string here would be a very natural way to say "we pass
> all the refs through our hook".

Yes, this is a good advice. Previously I cannot pass all the refs through
the new hook unless set two config items like:

         [transfer]
             hiderefs = hook:HEAD
             hiderefs = hook:refs

I thinks it is a good idea to use only one config item to replace them:

         [transfer] hiderefs = hook:
> 
> By the way, how does the negated entry work with this new one?  For
> static ones,
> 
> 	[transfer] hiderefs = !refs/heads/
> 
> would hide everything other than refs/heads/ hierarchy, I suppose.
> Would we spell
> 
> 	[transfer] hiderefs = hook:!refs/heads/
> 
> or
> 
> 	[transfer] hiderefs = !hook:refs/heads/
> 
> to say "send everything outside the branches to hook"?  If the
> former, you'd also need to special case "!" the same way as you
> special case an empty string (in short, I am saying that the special
> case only for an empty string does not make much sense).

In my patch I put the "!" after the "hook:", and negate passing all the refs to the
hook would like

         [transfer] hiderefs = hook:!

however according to the match mechanism of hiderefs, it will be better to delete
the config item above. If there are no config item, the hook will not be called.

So if I want to pass all the refs but some scope of them, it will be like (use a empty
string to match all the refs)

         [transfer]
             hiderefs = hook:
             hiderefs = hook:!refs/pull/

which means pass all the refs except for the ones begins with 'refs/pull/'


> How does this mechanism work with gitnamespaces (see "git config --help"
> and read on transfer.hideRerfs)?

In my patch Git will send refname and refnamefull(with namepsace) to the hook, the hook
will check it and response with 'hide' or not. In the following example, the letter
'G' stands for 'git-receive-pack' or 'git-upload-pack' and the letter 'H' stands for
this hook

       # Send reference filter request to hook
       G: PKT-LINE(ref <refname>:<refnamefull>)
       G: flush-pkt

       # Receive result from the hook.
       # Case 1: this reference is hidden
       H: PKT-LINE(hide)
       H: flush-pkt

       # Case 2: this reference can be advertised
       H: flush-pkt

I'm not sure if it is suitable or not, I think it will be better to send both the refname
and the refnamefull to the hook.

> That's a somewhat duplicated code.  I wonder
> 
> 	/* no need for "hook" variable anymore */
> 	struct string_list **refs_list= &hide_refs;
> 
> 	if (strip "hook:" prefix from value)
> 		refs_list = &hook_hide_refs;
> 		...
> 	if (!*refs_list) {
>        	*refs_list = xcalloc(1, sizeof(*refs_list));
> 		(*refs_list)->strdup_strings = 1;
> 	}
> 	string_list_append(*refs_list, ref);
> 		
> would be a better organization.  I dunno.

Agree, it looks better, I will do it.

> 
>> +
>> +	/*
>> +	 * Once hide-refs hook is invoked, Git need to do version negotiation,
>> +	 * with it, version number and process name ('uploadpack' or 'receive')
>> +	 * will send to it in pkt-line format, the proccess name is recorded
>> +	 * by hide_refs_section
>> +	 */
> 
> Grammar.

Will fix.

> On Sep 17, 2022, at 01:52, Junio C Hamano <gitster@xxxxxxxxx> wrote:
> 
> Junio C Hamano <gitster@xxxxxxxxx> writes:
> 
> ... ...
> 
>> +	if (hook && hide_refs_section.len == 0)
>> +		strbuf_addstr(&hide_refs_section, section);
>> +
> 
> that is only set inside the body of the if statement of the first
> conditional that ensures that we are reading *.hiderefs variable,
> but it would make more sense to move it inside it.

Agree, it will be better to move it inside.

> 
> Or even better would be to clean the function up with a preliminary
> patch to return early when we are not looking at *.hiderefs variable,
> perhaps like the attached, and then build on top.
> 
> ... ...
> 
> +
> +	/*
> +	 * "section" is either "receive" or "uploadpack"; are we looking
> +	 * at transfer.hiderefs or $section.hiderefs?
> +	 */
> +	if (strcmp("transfer.hiderefs", var) &&
> +	    !(!parse_config_key(var, section, NULL, NULL, &key) &&
> +	      !strcmp(key, "hiderefs")))
> +		return 0; /* neither */
> +	if (!value)
> +		return config_error_nonbool(var);
> +	ref = xstrdup(value);
> +	len = strlen(ref);
> +	while (len && ref[len - 1] == '/')
> +		ref[--len] = '\0';
> +	if (!hide_refs) {
> +		CALLOC_ARRAY(hide_refs, 1);
> +		hide_refs->strdup_strings = 1;
> 	}
> +	string_list_append(hide_refs, ref);
> +
> 	return 0;
> }

Thanks for the advice here, I Will do it.




[Index of Archives]     [Linux Kernel Development]     [Gcc Help]     [IETF Annouce]     [DCCP]     [Netdev]     [Networking]     [Security]     [V4L]     [Bugtraq]     [Yosemite]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Linux SCSI]     [Fedora Users]

  Powered by Linux