Hi Torsten, On Fri, 2 Sep 2022, tboegi@xxxxxx wrote: > diff --git a/diff.c b/diff.c > index b5df464de5..cf38e1dc88 100644 > --- a/diff.c > +++ b/diff.c > [...] > @@ -2753,10 +2754,14 @@ static void show_stats(struct diffstat_t *data, struct diff_options *options) > if (slash) > name = slash; > } > + if (len > utf8_strwidth(name)) > + num_padding_spaces = len - utf8_strwidth(name); Here, we determine how many spaces are needed for padding. The value is later used in three instances, and from the diff it is not immediately obvious that all code paths are covered. I did verify locally that this is the case, though, so all is good. > > if (file->is_binary) { > - strbuf_addf(&out, " %s%-*s |", prefix, len, name); > - strbuf_addf(&out, " %*s", number_width, "Bin"); This was already a bit wasteful by calling `strbuf_addf()` twice, where one time would have sufficed. (This applies to the other two code paths below, too.) > + strbuf_addf(&out, " %s%s ", prefix, name); > + if (num_padding_spaces) > + strbuf_addchars(&out, ' ', num_padding_spaces); > + strbuf_addf(&out, "| %*s", number_width, "Bin"); Instead of fixing this, we now add yet another `strbuf*()` call. But this could be done more elegantly, via a single `strbuf_addf()` call: strbuf_addf(&out, "%s%s%*s | %*s", prefix, name, num_padding_spaces, "", number_width, "Bin"); By the way, it would flow much better, I think, if we used the short-and-sweet variable name `padding` instead of `num_padding_spaces`. > if (!added && !deleted) { > strbuf_addch(&out, '\n'); > emit_diff_symbol(options, DIFF_SYMBOL_STATS_LINE, > @@ -2776,8 +2781,10 @@ static void show_stats(struct diffstat_t *data, struct diff_options *options) > continue; > } > else if (file->is_unmerged) { > - strbuf_addf(&out, " %s%-*s |", prefix, len, name); > - strbuf_addstr(&out, " Unmerged\n"); > + strbuf_addf(&out, " %s%s ", prefix, name); > + if (num_padding_spaces) > + strbuf_addchars(&out, ' ', num_padding_spaces); > + strbuf_addstr(&out, "| Unmerged\n"); This can become strbuf_addf(&out, " %s%s%*s | Unmerged", prefix, name, padding, ""); instead. > emit_diff_symbol(options, DIFF_SYMBOL_STATS_LINE, > out.buf, out.len, 0); > strbuf_reset(&out); > @@ -2803,8 +2810,10 @@ static void show_stats(struct diffstat_t *data, struct diff_options *options) > add = total - del; > } > } > - strbuf_addf(&out, " %s%-*s |", prefix, len, name); > - strbuf_addf(&out, " %*"PRIuMAX"%s", > + strbuf_addf(&out, " %s%s ", prefix, name); > + if (num_padding_spaces) > + strbuf_addchars(&out, ' ', num_padding_spaces); > + strbuf_addf(&out, "| %*"PRIuMAX"%s", > number_width, added + deleted, > added + deleted ? " " : ""); And this reads better as strbuf_addf(&out, " %s%s%*s | %*"PRIuMAX"%s", prefix, name, padding, "", number_width, added + deleted, added + deleted ? " " : ""); If we modify the code in this manner, we avoid repeating a pretty unreadable pattern three times, using a much more readable pattern instead. Random note: The existing code (not your fault) is hard to follow because it calls `show_graph()` for `add` and `del` always, even if their counts are zero (in which case `show_graph()` returns early), while the separating space is appended in the otherwise unrelated `strbuf_addf()` call before that, but uses the (unscaled) `added + deleted` as condition for that separator. It would be much easier to follow like this: strbuf_addf(&out, " %s%s%*s | %*"PRIuMAX", prefix, name, padding, "", number_width, added + deleted); if (add || del) { strbuf_addch(&out, ' '); show_graph(&out, '+', add, add_c, reset); show_graph(&out, '-', del, del_c, reset); } But I consider this #leftoverbits, not something to burden your contribution with. Ciao, Dscho > show_graph(&out, '+', add, add_c, reset);