On Sat, Aug 20 2022, Jeff King wrote: > On Fri, Aug 19, 2022 at 10:58:08PM +0200, Ævar Arnfjörð Bjarmason wrote: > >> Yes, I spoke too soon, sorry. We still need ((unused)). FWIW the below >> on top of master and doing: > > Right. Using ((deprecated)) is really just a substitute for the variable > renaming part. > > And I agree it works as advertised, though I think I prefer the > variable-renaming version. > > One, it feels like we're abusing the deprecated attribute here. The Definitely, but structurally it seems like a better pick. I.e. isn't the only problem with it the "deprecated" and its interaction with -Wno-deprecated. If the exact same feature existed as a "insert-custom-warning", which would work exactly "deprecated" without the default warning "prefix" would you think this would fit perfectly? > ... > -Wno-deprecated-declarations to get around _actual_ deprecated warnings > (e.g., compiling with OPENSSL_SHA1=Yes). And doing so would be cutting > out half the protection of UNUSED() in that case. This is mildly annoying, but I don't really think it's a practical issue. We're talking about running this without -Wno-deprecated-declarations in CI, and by default. For unused parameters it's enough that we're catching them somewhere, or in common compilation settings, we don't need to catch them *everywhere*, do we? IOW is anyone writing patches where they're testing with -Wno-deprecated-declarations *and* adding unused parameters *and* won't test without -Wno-deprecated-declarations before submitting them, *and* nobody else will catch it? > Likewise, one thing I like about the renaming is that it fails > compilation regardless of -Werror. So it will be caught in any compile, > no matter what. And I do automatically compile without DEVELOPER=1 when > on a detached HEAD, because historical commits often trigger warnings. > Go back far enough and OPENSSL_SHA1 was the default, which generates > lots of warnings these days. :) *nod*, I think this also goes the other way. It's nice to be able to use DEVOPTS=no-error to "get past" various minor issues. I consider an unused parameter as being a minor issue. E.g. when ad-hoc cherry-picking something to test on an older version it can be annoying to have to make larger changes when a DEVOPTS=no-error would do. > And finally, I actually prefer the parentheses of: > > static int register_ref(const char *refname, const struct object_id *oid, > int UNUSED(flags), void *UNUSED(cb_data)) ...and now to the real reason for the follow-up. You/Junio were CC'd, but this is breaking coccinelle, see: https://lore.kernel.org/git/220825.86ilmg4mil.gmgdl@xxxxxxxxxxxxxxxxxxx/ So, bikeshedding-wise I don't care to argue the point. But between odd syntax highlighting and now one analysis tool barfing on it it's a bit more than a bikeshed :)