[PATCH v2 0/4] run-command.h: rename "env_array" to "env"

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Follow-up 32ec72c3e1 (Merge branch 'ab/run-command', 2021-12-15) and
rename the "env_array" member to simply "env" in the "struct
child_process".

Changes since v1:

 * Added a commit to remove the coccinelle rule after its application,
   as suggested by Junio in
   https://lore.kernel.org/git/xmqqzgjdkxon.fsf@gitster.g/

 * Minor commit rewording for 4/4 to adjust for that new 3/4.

Ævar Arnfjörð Bjarmason (4):
  cocci: add a rename of "struct child_process"'s "env_array" to "env"
  run-command API: rename "env_array" to "env"
  cocci: remove env_array -> env migration
  run-command API users: use "env" not "env_array" in comments & names

 add-patch.c                 |  2 +-
 branch.c                    |  2 +-
 builtin/difftool.c          |  6 ++---
 builtin/receive-pack.c      | 32 +++++++++++++--------------
 builtin/stash.c             | 16 +++++++-------
 builtin/submodule--helper.c | 44 ++++++++++++++++++-------------------
 builtin/worktree.c          |  8 +++----
 connect.c                   |  9 ++++----
 connected.c                 |  2 +-
 daemon.c                    | 14 ++++++------
 editor.c                    |  2 +-
 hook.c                      |  2 +-
 http-backend.c              |  4 ++--
 object-file.c               |  2 +-
 pager.c                     |  4 ++--
 promisor-remote.c           |  2 +-
 run-command.c               | 19 ++++++++--------
 run-command.h               | 14 ++++++------
 sequencer.c                 | 18 +++++++--------
 submodule.c                 | 38 ++++++++++++++++----------------
 submodule.h                 |  4 ++--
 t/helper/test-run-command.c |  2 +-
 trailer.c                   |  2 +-
 transport-helper.c          |  2 +-
 wt-status.c                 |  2 +-
 25 files changed, 127 insertions(+), 125 deletions(-)

Range-diff against v1:
1:  b943ed5d5b7 = 1:  e3f33fce566 cocci: add a rename of "struct child_process"'s "env_array" to "env"
2:  51063a31b16 = 2:  5aeb6ec9117 run-command API: rename "env_array" to "env"
-:  ----------- > 3:  ca09da570ef cocci: remove env_array -> env migration
3:  8af76f39b9f ! 4:  5419f839c74 run-command API users: use "env" not "env_array" in comments & names
    @@ Metadata
      ## Commit message ##
         run-command API users: use "env" not "env_array" in comments & names
     
    -    Follow-up on the preceding commit which changed all references to the
    +    Follow-up on a preceding commit which changed all references to the
         "env_array" when referring to the "struct child_process" member. These
         changes are all unnecessary for the compiler, but help the code's
         human readers.
-- 
2.36.1.957.g2c13267e09b




[Index of Archives]     [Linux Kernel Development]     [Gcc Help]     [IETF Annouce]     [DCCP]     [Netdev]     [Networking]     [Security]     [V4L]     [Bugtraq]     [Yosemite]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Linux SCSI]     [Fedora Users]

  Powered by Linux