Another short series for db/fetch-pack, still in pu. Aside from optimizing the pipeline on the native transport (so we only invoke the remote process we need once vs. twice) I'm actually now quite comfortable with this whole series and think it is ready for next. I'm certainly running it in production, and will be until it is merged. The performance difference is too big for me (and at least some of my coworkers) to not be doing so. If there are any specific reasons why this topic is not ready for next or is unsuitable for merging please let me know so I can take the time to correct it. 1/5 Rename remote.uri to remote.url within remote handling internals 2/5 Refactor struct transport_ops inlined into struct transport 3/5 Always obtain fetch-pack arguments from struct fetch_pack_args These three are basic code cleanups for small issues that bothered me about the original implementation of builtin-fetch. Now is just as good of a time as any to cleanup the code and make it more maintainable. I think the overall total line count is reduced by these three patches. * Ensure builtin-fetch honors {fetch,transfer}.unpackLimit * Fix memory leaks when disconnecting transport instances Fixes two known (but minor) outstanding bugs. At this point I do not know of any other bugs in builtin-fetch so I would really appreciate testing reports from other people, especially those whose uses cases might stray outside of my workflow. Hah, I did not tell you my workflow. ;-) -- Shawn. - To unsubscribe from this list: send the line "unsubscribe git" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html