A minor code cleanup. Let's "return" from cmd_gc() instead of calling exit(). See 338abb0f045 (builtins + test helpers: use return instead of exit() in cmd_*, 2021-06-08) for other such cases. While we're at it add a \n to separate the variable declaration from the rest of the code in this block. Both of these changes make a subsequent change smaller and easier to read. This change isn't really needed for that subsequent change, but now someone viewing that future behavior change won't need to wonder why we're either still calling exit() here, or fixing it while we're at it. Signed-off-by: Ævar Arnfjörð Bjarmason <avarab@xxxxxxxxx> --- builtin/gc.c | 3 ++- 1 file changed, 2 insertions(+), 1 deletion(-) diff --git a/builtin/gc.c b/builtin/gc.c index bcef6a4c8da..900ccfb8d48 100644 --- a/builtin/gc.c +++ b/builtin/gc.c @@ -611,9 +611,10 @@ int cmd_gc(int argc, const char **argv, const char *prefix) } if (detach_auto) { int ret = report_last_gc_error(); + if (ret < 0) /* an I/O error occurred, already reported */ - exit(128); + return 128; if (ret == 1) /* Last gc --auto failed. Skip this one. */ return 0; -- 2.34.1.898.g5a552c2e5f0